HDU 4586 (数学)

Play the Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2213    Accepted Submission(s): 729
Special Judge


Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
 

Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
 

Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
 

Sample Input
  
  
6 1 2 3 4 5 6 0 4 0 0 0 0 1 3
 

Sample Output
  
  
3.50 0.00
 


题意:一个轮盘有n个格子转到每个格子有对应的金钱,然后转到其中m个格子会获得

再转一次的机会,问获得金钱的数学期望.

假设轮盘上所有的金钱是sum,获得再转一次的几率是p,显然p=m/n,然后转一次获得

金钱的期望是sum/n,假设是k,总的获得的期望就是(k+k*p+k*p^2+k*p^3+....)=k/(n-m)

(等比数列求极限)

#include <bits/stdc++.h>
using namespace std;

int n, m;

int main () {
  //  freopen ("in.txt", "r", stdin);
    while (cin >> n) {
        double sum = 0;
        double x;
        for (int i = 0; i < n; i++) {
            cin >> x;
            sum += x;
        }
        cin >> m;
        for (int i = 0; i < m; i++)
            cin >> x;
        if (sum == 0) {
            printf ("0.00\n");
        }
        else if (n == m) {
            printf ("inf\n");
        }
        else {
            printf ("%.2f\n", sum/(n-m));
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值