POJ2817 WordStack

WordStack
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2944 Accepted: 1023

Description

As editor of a small-town newspaper, you know that a substantial number of your readers enjoy the daily word games that you publish, but that some are getting tired of the conventional crossword puzzles and word jumbles that you have been buying for years. You decide to try your hand at devising a new puzzle of your own. 

Given a collection of N words, find an arrangement of the words that divides them among N lines, padding them with leading spaces to maximize the number of non-space characters that are the same as the character immediately above them on the preceding line. Your score for this game is that number.

Input

Input data will consist of one or more test sets. 

The first line of each set will be an integer N (1 <= N <= 10) giving the number of words in the test case. The following N lines will contain the words, one word per line. Each word will be made up of the characters 'a' to 'z' and will be between 1 and 10 characters long (inclusive). 

End of input will be indicated by a non-positive value for N .

Output

Your program should output a single line containing the maximum possible score for this test case, printed with no leading or trailing spaces.

Sample Input

5 
abc 
bcd 
cde 
aaa 
bfcde 
0

Sample Output

8

Hint

Note: One possible arrangement yielding this score is: 
aaa 

abc 

 bcd

  cde 

bfcde

Source


(暴力) 手写爆搜TLE,改用STL的next_permutation 过了
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
int n,ans;
bool vis[20];
vector<string> sst;
int mat[15][15];
void backtrack(vector<int>&k,int c){
	if(k.size()==n){
		int sum = 0;
		for(int i = 0; i < k.size()-1; i++){
				sum += mat[k[i]][k[i+1]];
		}
		ans = max(ans,sum);
		return;
	}
	for(int i = 0; i < sst.size(); i++){
		if(!vis[i]){
			vis[i] = 1;
			k.push_back(i);
			backtrack(k,i);
			k.pop_back();
			vis[i] = 0;
		}
	}
}
int getlcs(string a,string b){
	int k = 0;
	for(int i = 0; i < a.size(); i++){
		for(int j = 0; j < b.size(); j++){
			int tl = i,tb = j,tmp = 0;
			while(tl<a.size() && tb<b.size()){
				if(a[tl]==b[tb]){
					tmp++;
				}
				tl++;
				tb++;
			}
			k = max(k,tmp);
		}
	}
	return k;
}
void init(){
	ans = 0;
	for(int i = 0; i < sst.size(); i++){
		for(int j = i+1; j < sst.size(); j++){
			mat[i][j] = getlcs(sst[i],sst[j]);
			mat[j][i] = mat[i][j];
		}	
	}
}
int main(){
	while(~scanf("%d",&n) && n>0){
		sst.clear();
		for(int i = 0; i < n; i++){
			string tmp;
			cin >> tmp;
			sst.push_back(tmp);
		}
		vector<int> k;
		for(int i = 0; i <= n-1; i++)	 k.push_back(i);
		init();
		do{
			int sum = 0;
			for(int i = 0; i < k.size()-1; i++){
				sum += mat[k[i]][k[i+1]];
			}
			ans = max(ans,sum);
		}while(next_permutation(k.begin(),k.end()));		
		cout<<ans<<endl;
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值