ZOJ3380- Patchouli's Spell Cards(概率DP+计数)

Patchouli's Spell Cards

Time Limit: 7 Seconds      Memory Limit: 65536 KB

Patchouli Knowledge, the unmoving great library, is a magician who has settled down in the Scarlet Devil Mansion (紅魔館). Her specialty is elemental magic employing the seven elements fire, water, wood, metal, earth, sun, and moon. So she can cast different spell cards like Water Sign "Princess Undine", Moon Sign "Silent Selene" and Sun Sign "Royal Flare". In addition, she can combine the elements as well. So she can also cast high-level spell cards like Metal & Water Sign "Mercury Poison" and Fire, Water, Wood, Metal & Earth Sign "Philosopher's Stones" .

Assume that there are m different elements in total, each element has n different phase. Patchouli can use many different elements in a single spell card, as long as these elements have the same phases. The level of a spell card is determined by the number of different elements used in it. When Patchouli is going to have a fight, she will choose m different elements, each of which will have a random phase with the same probability. What's the probability that she can cast a spell card of which the level is no less than l, namely a spell card using at least l different elements.

Input

There are multiple cases. Each case contains three integers 1 ≤ m, n, l ≤ 100. Process to the end of file.

Output

For each case, output the probability as irreducible fraction. If it is impossible, output "mukyu~" instead.

Sample Input
7 6 5
7 7 7
7 8 9
Sample Output
187/15552
1/117649
mukyu~
 
题目意思:有m个元素,每个元素有n种相,现在从m个元素中,随机抽取每一种元素的一种相,每种相取到的概率相同,相同的相可以融合,融合的个数就为它的度,问你最大的度大于等于L的概率。
 
做法 :
JAVA大数
dp[n][m] 表示的意思是 前n种相,用了m个元素,符合最大的度小于L的方案个数。
dp[n][m] = sum(dp[n-1][m-k]*count[M-(m-k)][k])
 
import java.util.*;
import java.math.*;


public class Main {
	static int maxn = 110;
	public static BigInteger[][] dp =new BigInteger[110][110];
	public static BigInteger[][] count = new BigInteger[110][110];
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		for(int i = 0; i < maxn; i++){
			count[i][0] = BigInteger.ONE;
			count[i][i] = BigInteger.ONE;
			for(int j = 1; j < i; j++){
				count[i][j] = count[i-1][j].add(count[i-1][j-1]);
			}
		}
		Scanner scan =  new Scanner(System.in);
		while(scan.hasNextInt()){
			int  m = scan.nextInt();
			int  n =  scan.nextInt();
			int  l = scan.nextInt();
			BigInteger nn = BigInteger.valueOf(n).subtract(BigInteger.ONE);
			BigInteger fm = BigInteger.valueOf(n).pow(m),fz = BigInteger.ZERO;
			if(l > m){
				System.out.println("mukyu~");
			}else{
				for(int i = 0; i <= n; i++)
					for(int j = 0; j <= m; j++)
						dp[i][j] = BigInteger.ZERO;
				
				dp[0][0] = BigInteger.ONE;
				for(int i = 1; i <= n; i++){
					for(int j = 0; j <= m; j++){
						for(int k = 0;  k <= j&& k <l; k++){
							dp[i][j] = dp[i][j].add(dp[i-1][j-k].multiply(count[m-(j-k)][k]));   
						}
					}
				}
				fz = fm.subtract(dp[n][m]);
				BigInteger gcd = fz.gcd(fm);
				fz = fz.divide(gcd);
				fm = fm.divide(gcd);
				System.out.println(fz+"/"+fm);
			}
			
		}
		scan.close();
	}

}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值