HDU5586(最大子序列变形)

Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 955 Accepted Submission(s): 499

Problem Description
There is a number sequence A1,A2….An,you can select a interval [l,r] or not,all the numbers Ai(l≤i≤r) will become f(Ai).f(x)=(1890x+143)mod10007.After that,the sum of n numbers should be as much as possible.What is the maximum sum?

Input
There are multiple test cases.
First line of each case contains a single integer n.(1≤n≤105)
Next line contains n integers A1,A2….An.(0≤Ai≤104)
It’s guaranteed that ∑n≤106.

Output
For each test case,output the answer in a line.

Sample Input
2
10000 9999
5
1 9999 1 9999 1

Sample Output
19999
22033

没什么好说的就是最大子序列,判断的条件变一下就好了。

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"
using namespace std;
int main()
{
    int num;
    while(~scanf("%d",&num))
    {
        int list[100020];
        for(int i=1;i<=num;i++)
            scanf("%d",&list[i]);
        int nowl=1,nowr=1;
        int fmax=0;
        int fnow=0;
        int now=0;
        int maxl=0;
        int maxr=0;
        list[0]=0;
        for(int i=1;i<=num;i++)
        {
            nowr=i;
            now+=list[i];
            fnow+=(1890*list[i]+143)%10007;
            if(fnow<now)
            {
                nowl=i+1;
                fnow=0;
                now=0;
                continue;
            }
            if(fnow-now>=fmax)
            {
                maxl=nowl;
                maxr=nowr;
                fmax=fnow-now;
            }
        }
        int ans=0;
        for(int i=1;i<maxl;i++)
            ans+=list[i];
        for(int i=maxl;i<=maxr&&maxl!=0;i++)
            ans+=(1890*list[i]+143)%10007;
        for(int i=maxr+1;i<=num;i++)
            ans+=list[i];
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值