HDU1394 Minimum Inversion Number(线段树)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17169 Accepted Submission(s): 10439

Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output
For each case, output the minimum inversion number on a single line.

Sample Input
10
1 3 6 9 0 8 5 7 4 2

Sample Output
16

Author
CHEN, Gaoli

Source
ZOJ Monthly, January 2003

Recommend
Ignatius.L | We have carefully selected several similar problems for you: 1698 1540 1542 1255 2795
首先要算一下当前序列的逆序数,这个用线段树优化,暴力大概是会挂。求完之后利用一个神奇的结论sum=sum-a[i]+(n-a[i]-1)也就是把数列的第一个依次放到队位去,看看逆序数会不会变得更小,最小的就是我们要的答案。

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"

#define MAXSIZE 500

using namespace std;
int min(int a, int b)
{
    if (a < b)
        return a;
    else
        return b;
}
int n, m;
int num[MAXSIZE];


typedef struct
{
    int cnt;
    int left, right;
}NODE;



NODE tree[MAXSIZE * 20];


int build(int root,int lf,int rt)
{
    int mid;
    tree[root].left = lf;
    tree[root].right = rt;
    if (lf == rt)
        return tree[root].cnt = 0;
    mid = (lf + rt) / 2;
    int a, b;
    a = build(2 * root, lf, mid);
    b = build(2 * root + 1, mid + 1, rt);

    return tree[root].cnt=0;;
}

int find(int root, int lf, int rt)
{
    if (tree[root].left > rt || tree[root].right < lf)
        return 0;
    if (lf <= tree[root].left&&tree[root].right <= rt)
        return tree[root].cnt;
    int a, b;
    a = find(2 * root, lf, rt);
    b = find(2*root + 1, lf, rt);
    return a+b;

}

int update(int root, int pos)
{
    if (pos < tree[root].left || tree[root].right < pos)
        return tree[root].cnt;
    if (tree[root].left == pos&&tree[root].right == pos)
        return ++tree[root].cnt;

    int a, b;
    a = update(2 * root, pos);
    b = update(2 * root + 1, pos);

    tree[root].cnt = a+b;
    return tree[root].cnt;
}

int val[5005];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        build(1,1,n);
        int sum=0;
        int ans=0;
        int a[5005];
        for(int i=1;i<=n;i++)
        {
            int now;
            scanf("%d",&now);
            now++;
            a[i]=now;
            update(1,now);
            val[i]=find(1,now+1,n);
            sum+=val[i];
        }
        ans=sum;
        for(int i=1;i<=n;i++)
        {
            sum=sum-a[i]+1+(n-a[i]+1-1);
            ans=min(ans,sum);
        }
        printf("%d\n",ans);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值