HDU 2476 String painter 区间dp

M - String painter
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 

Input

Input contains multiple cases. Each case consists of two lines: 
The first line contains string A. 
The second line contains string B. 
The length of both strings will not be greater than 100. 
 

Output

A single line contains one integer representing the answer.
 

Sample Input

     
     
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
 

Sample Output

     
     
6 7

 



思路是先求出从空白串转化到b串要花多少次

然后比较a串和b串相同元素的个数在优化答案

ACcode;

#include<iostream>
#include<cstdio>
#include<cstring>
#define maxn 120
using namespace std;
int dp[maxn][maxn],ans[maxn];
char a[maxn],b[maxn];
int main(){
    while(scanf("%s\n%s",a+1,b+1)!=EOF){
        int n=strlen(a+1);
        for(int i=0;i<=n;++i)dp[i][i]=1;
        for(int l=2;l<=n;++l)
        for(int i=1;i<=n-l+1;++i){
            int j=i+l-1;
            dp[i][j]=dp[i+1][j]+1;
            for(int k=i+1;k<=j;++k)
                if(b[k]==b[i])
                    dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]);
        }
        ans[0]=0;
        for(int i=1;i<=n;++i){
            ans[i]=dp[1][i];
            if(a[i]==b[i])ans[i]=ans[i-1];
            for(int j=1;j<=i;++j)ans[i]=min(ans[i],dp[j+1][i]+ans[j]);
        }
        printf("%d\n",ans[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值