hdu--1065I Think I Need a Houseboat(别想复杂,一道数学公式题!)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1065
I Think I Need a Houseboat
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15683 Accepted Submission(s): 4338

Problem Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

Input
The first line of input will be a positive integer indicating how many data sets will be included (N).

Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output
For each data set, a single line of output should appear. This line should take the form of:

“Property N: This property will begin eroding in year Z.”

Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer.

After the last data set, this should print out “END OF OUTPUT.”

Notes:

  1. No property will appear exactly on the semicircle boundary: it will either be inside or outside.

  2. This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.

  3. All locations are given in miles.

Sample Input
2
1.0 1.0
25.0 0.0

Sample Output
Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

题意:土地以半圆形状,每年50平方公里侵蚀,有0.5πrr=S(面积)
即year = π
rr/100 (rr就是点到原点距离的平方)

先看看大家容易犯错的代码(超时):

#include<stdio.h>
#include<math.h>
#define  PI 3.1415926
int main()
{
    int t;
    //double pi=3.14;
	double x,y,r,yy,year;
	int count;
	int temp = 0;
    scanf("%d",&t);
	while(t--)
	{
		scanf("%lf%lf",&x,&y);
		r=sqrt(x*x+y*y);
		count=0;
		yy=0;
		year=0;
		//超时的原因在于这个循环
		while(year<r)
		{
			yy=yy+50.0;
			year=sqrt((yy*2)/PI);
			count++;
		}
		printf("Property %d: This property will begin eroding in year %d.\n",++temp,count);
	}
	printf("END OF OUTPUT.\n");
    return 0;
}

正确解答:

#include<stdio.h>
#include<math.h>
#define  PI 3.1415926
int main()
{
    int t;
    //double pi=3.14;
	double x,y,r,sum;
	int count;
	int temp=0;
    scanf("%d",&t);
     while(t--)
     {
         scanf("%lf%lf",&x,&y);
         r=sqrt(x*x+y*y);
		 sum=PI*r*r/2/50;
		 //这里的if也可以不要,因为PI为小数
		 if(((int )sum)==sum)
			 count=(int)sum;
		 else
			 count=(int)sum+1;
            printf("Property %d: This property will begin eroding in year %d.\n",++temp,count);
     }
     printf("END OF OUTPUT.\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值