L2-012 关于堆的判断 (25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

思路:

        1.建立小根堆

        输入第i个数时,先将该数放在堆的第i个位置(i从1开始),随后再比较它和它父亲节点值的大小,若父亲节点的值大于该节点则交换,直至其大于其父亲节点或到根停止。

void insert(int x) {
    tr[idx] = x;
    for (int t = idx; t > 1; t >>=1) {
        if (tr[(t >> 1)] > tr[t])swap(tr[(t >> 1)], tr[t]);
        else break;
    }
    idx++;
}

        2.保存小根堆中节点的位置

        建堆结束后,用map保存各个数在堆中的位置,用于后续判断.

        3.输入并比较 

#include<bits/stdc++.h>
using namespace std;

const int N = 10100;
int n, m, idx=1, tr[N];
map<int, int>mp;
void insert(int x) {
    tr[idx] = x;
    for (int t = idx; t > 1; t >>=1) {
        if (tr[(t >> 1)] > tr[t])swap(tr[(t >> 1)], tr[t]);
        else break;
    }
    idx++;
}
int main() {
    
    scanf("%d %d", &n, &m);
    for (int i = 0; i < n; ++i) {
        int x;
        scanf("%d", &x);
        insert(x);
    }
    for (int i = 1; i <= n; ++i)
        mp[tr[i]] = i ;
    	
    for (int i = 0; i < m; ++i) {
        int a;
        scanf("%d", &a);
        string s1; cin >> s1;
        if (s1 == "and") {
            int b; scanf("%d", &b);
            cin >> s1 >> s1;
            if (mp[a] / 2 == mp[b] / 2)puts("T");
            else puts("F");
        }
        else {
            cin >> s1;
            if (s1 == "a") {
                cin >> s1 >> s1;
                int b; scanf("%d", &b);
                if (mp[a] / 2 == mp[b])puts("T");
                else puts("F");
            }
            else {
                cin >> s1;
                if (s1 == "root") {
                    if (a == tr[1])puts("T");
                    else puts("F");
                }
                else {
                    cin >> s1;
                    int b; scanf("%d", &b);
                    if (mp[b] / 2 == mp[a])puts("T");
                    else puts("F");
                }
            }
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值