杭电1042 N!

6 篇文章 0 订阅
2 篇文章 0 订阅

N!

 


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 
CODE:
#include <stdio.h>
#include <string.h>     
int main()
{
	int i,j,a,n,len,str[70000];    //要开到70000,不然wa 
	while(~scanf("%d",&n))
	{
		str[0]=1;
		len=1;
		for(i=1;i<=n;i++)
		{
			a=0;
			for(j=0;j<len;j++)
			{
				str[j]=str[j]*i+a;
				if(str[j]>9)
				{
					a=str[j]/10;
					str[j]%=10;
				}
				else
				a=0;
			}
			//printf("%d %d\n",j,len);
			while(a)
			{
				str[len]=a%10;
				a/=10;
				len++;
			}
		}
		for(i=len-1;i>=0;i--)
		printf("%d",str[i]);
		printf("\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值