Toxophily

Toxophily

时间限制: 1 Sec   内存限制: 128 MB
提交: 41   解决: 21
[ 提交][ 状态][ 论坛]

题目描述

The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on. We all like toxophily. Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him? Now given the object’s coordinates, please calculate the angle between the arrow and x-axis at Bob’s point. Assume that g=9.8N/m.

输入

The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow’s exit speed. Technical Specification 1. T <= 100. 2. 0 <= x, y, v <= 10000.

输出

For each test case, output the smallest answer rounded to six fractional digits on a separated line. Output “-1”, if there’s no possible answer. Please use radian as unit.

样例输入

30.222018 23.901887 121.90918339.096669 110.210922 20.270030138.355025 2028.716904 25.079551

样例输出

1.561582-1-1
y=a(x-b)^2+c 求出系数a,b,c然后二分就好了
#include<cstdio>
#include<cmath>
using namespace std;
#define PI 3.141592653
#define g 9.8
int main(){
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T; 
    double x,y,v;
    scanf("%d",&T);
    while(T--){
        scanf("%lf%lf%lf",&x,&y,&v);
        int i,flag=0;
        double low,high,mid;
        low=0; high=PI/2;
        for(i=0;i<1000;i++){
            double a,b,c;
            mid=(low+high)/2;
            a=-g*tan(mid)/(v*v*sin(2*mid));
            b=v*v*sin(2*mid)/(2*g);
            c=v*v*sin(mid)*sin(mid)/(2*g);
            if(fabs(y-(a*(x-b)*(x-b)+c))<0.0000001){
                flag=1;
                break;
            }
            if(y>a*(x-b)*(x-b)+c)
                low=mid;
            else
                high=mid;
        }
        if(flag==0)
            printf("-1\n");
        else
            printf("%.6lf\n",mid);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值