HDU-6025-Coprime Sequence(枚举+前后缀)

Coprime Sequence

Problem Description

Do you know what is called "Coprime Sequence’’? That is a sequence consists of n positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
"Coprime Sequence’’ is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input

The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers a1,a2,…,an(1≤ai≤109), denoting the elements in the sequence.

Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.

Sample Input

3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8
 

Sample Output

1
2
2

解题思路:

简单思维题,枚举去掉每个n剩下的数的GCD值,那么可以开两个数组,一个往前gcd一个往后,这样删除一个数时就可以o1计算剩下的数的gcd值。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
typedef long long ll;
const int mod = 1e9+7;
const int N = 1e6+10;
ll front[N];
ll back[N];
ll a[N];

ll gcd(ll a1,ll b1)
{
    if (a1 < b1)
        swap(a1,b1);
    return b1 == 0 ? a1 : gcd(b1,a1%b1);
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        for(int i = 0 ; i < n ; i ++)
            cin>>a[i];
        front[0] = a[0];
        for(int i = 1 ; i < n ; i ++)
            front[i] = gcd(a[i],front[i-1]);
        back[n-1] = a[n-1];
        for(int i = n- 2 ; i >= 0 ; i --)
            back[i] = gcd(a[i],back[i+1]);
        ll ans = max(front[n-2],back[1]);
        for(int i = 1 ; i < n-1 ; i ++)
        {
            ans = max(ans,gcd(front[i-1],back[i+1]));
        }
        cout<<ans<<endl;
    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值