KMP入门必做-匹配



Given two sequences of numbers : a 1  1, a 2  2, ...... , a N  N, and b 1  1, b 2  2, ...... , b M  M (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a K  K = b 1  1, a K+1  K+1 = b 2  2, ...... , a K+M1  K+M−1 = b M  M. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a 1  1, a 2  2, ...... , a N  N. The third line contains M integers which indicate b 1  1, b 2  2, ...... , b M  M. All integers are in the range of 1000000,1000000  −1000000,1000000

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6

-1

由于之前学了KMP,且KMP的模板确实在入门题里面挺好套的hhhh,当然我还是弄懂了KMP的算法,毕竟数据结构考过。(突然笑炸

AC代码><:

#include<iostream>
#include<cstdio>
using namespace std;
int a[1000005],b[10005],i,j;
int fail[10010];
void ge(int m){
i=1; fail[1]=0; j=0;
while(i<m){if(j==0||b[i]==b[j])
{
++i; ++j;
if(b[i]!=b[j]) fail[i]=j;
else fail[i]=fail[j];
}
else j=fail[j];
}
}
int de(int n,int m){
i=1; j=1;
while(i<=n&&j<=m)
{
if(j==0||a[i]==b[j])
{
++i; ++j;
}
else j=fail[j];
}
if(j>m) return i-m;
else return -1;
}
int main(){
int t,n,m;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
for(j=1;j<=m;j++)
{
scanf("%d",&b[j]);
}
ge(m);
int r=de(n,m);
printf("%d\n",r);
}
return 0;
}


End

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值