Description
n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n. However, only two of them (labelled a and b, where 1 ≤ a ̸= b ≤ n) withstood the test of time.
Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i ̸∈ {a, b} and 1 ≤ i ≤ n) if there exist two pagodas standing erect, labelled j and k respectively, such that i = j + k or i = j − k. Each pagoda can not be rebuilt twice.
This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
Input
The first line contains an integer t (1 ≤ t ≤ 500) which is the number of test cases. For each test case, the first line provides the positive integer n (2 ≤ n ≤ 20000) and two different integers a and b.
Output
For each test case, output the winner (‘Yuwgna’ or ‘Iaka’). Both of them will make the best possible decision each time.
Sample Input
16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12
Sample Output
Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka
题解:
这道题关键在于a和b,他们决定了最小间距(因为每次选定距离都与他俩有关,当把n遍历一遍后,会发现相邻两个的距离为gcd(a,b)),所以用n/gcd(a,b)便可算出最终个数。
代码如下:
#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<cmath>
#include<stack>
#include<queue>
#include<map>
#include<set>
#define max(a,b) (a>b?a:b)
#define min(a,b) (a<b?a:b)
#define swap(a,b) (a=a+b,b=a-b,a=a-b)
#define maxn 100007
#define N 100000000
#define INF 0x3f3f3f3f
#define mod 1001113
//#define e 2.718281828459045
#define eps 1.0e18
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define read(x) scanf("%d",&x)
#define put(x) prllf("%d\n",x)
#define memset(x,y) memset(x,y,sizeof(x))
#define Debug(x) cout<<x<<" "<<endl
#define lson i << 1,l,m
#define rson i << 1 | 1,m + 1,r
#define ll long long
//std::ios::sync_with_stdio(false);
//cin.tie(NULL);
//const int maxn=;
using namespace std;
int main()
{
int t,s=1;
cin>>t;
while(t--)
{
int n,a,b;
cin>>n>>a>>b;
if(n/gcd(a,b)%2==0)
cout<<"Case #"<<s++<<": Iaka"<<endl;
else
cout<<"Case #"<<s++<<": Yuwgna"<<endl;
}
return 0;
}