Given N numbers, X1, X2, … , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i < j ≤ N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!
Note in this problem, the median is defined as the (m/2)-th smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.
Input
The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, … , XN, ( Xi ≤ 1,000,000,000 3 ≤ N ≤ 1,00,000 )
Output
For each test case, output the median in a separate line.
Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8
水题
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;
typedef long long ll;
const long long INF = 1000500;
ll n,s[100050],m;
bool fun(int mid)
{
ll t=0;
for(int i=0;i<n;i++)
{
ll c= upper_bound(s+i,s+n,s[i]+mid)-s-i-1;
t+=c;
}
return t<m;
}
int main()
{
while(~scanf("%d",&n))
{
m=n*(n-1)/2;
if(m%2)
m=m/2+1;
else
m=m/2;
for(int i=0;i<n;i++)
scanf("%d",s+i);
sort(s,s+n);
ll l=0,r=s[n-1]-s[0];
while(r-l>1)
{
ll mid=(l+r)/2;
if(fun(mid))
l=mid;
else
r=mid;
}
cout<<r<<endl;
}
return 0;
}