City -hdoj 4496-并查集删边


Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
Input
First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
Sample Input
5 10 
0 1 
1 2 
1 3 
1 4 
0 2 
2 3 
0 4 
0 3 
3 4 
2 4
Sample Output
1 
1 
1 
2 
2 
2 
2 
3 
4 
5
算法:

//正常并查集是一条一条边的加,然后判断联通块,但这个刚好反过来,
//那么直接储存反过来记录查询就行了
#include <cstdio>  
#include <algorithm>  
#define INF 0x3f3f3f3f 
#define max1 100000+50
#define max2 10000+50
int par[max2],a[max1];
using namespace std;
struct Node{
	int a,b;	
}data[max1];
int find(int x)
{
	if(x!=par[x])
		return par[x]=find(par[x]);
	return x;	
}
void join(int a, int b)
{
	int fa = find(a);
	int fb = find(b);
	if (fa != fb)
		par[fa] = fb;
}

int main()
{
	int m,n;
	int ans;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		ans=n;//最初n个城市,连通块个数为n 
		for(int i = 0; i < m; i++)		
		scanf("%d %d",&data[i].a,&data[i].b);
		for(int i = 0; i < n; i++)
		par[i]=i;
		for(int i=m-1; i>=0;i--)//倒序查询合并 
	        {
	            a[i]=ans;
	            if(find(data[i].a)!=find(data[i].b))
	            {
	                ans--;//如果不连通就把他们连起来,个数减一 
	            }               
	            join(data[i].a,data[i].b);
	        }
	        for (int i=0;i<m;i++)
	        {
	            printf("%d\n",a[i]);
	        }
	}	
	return 0;	
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值