POJ3295 Tautology

36 篇文章 0 订阅

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not


构造一个逻辑表达式的计算器。

因为只有5个变量,所以可以遍历32个可能的取值,对每个可能的取值计算表达式的值。

如果某个取值使表达式为0则输出not结束程序。

#include <stdio.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <vector>
#include <iostream>
using namespace std;
char buf[65536];
int m[256];
int val;

#define get_val(c) ((val>>(m[c]-1)) & 1)

int get_res(char c, int a, int b){
	switch(c){
	case 'K':
		return a&b;
		break;
	case 'A':
		return a|b;
		break;
	case 'C':
		if(a==1 && b==0)
			return 0;
		else
			return 1;
		break;
	case 'E':
		return a==b;
	}
}

void process(){
	m['p']=5;m['q']=4;m['r']=3;m['s']=2;m['t']=1;
	int len = strlen(buf);
	for(val=0;val<32;++val){
		vector<int> ops;
		for(int i=len-1;i>=0;--i){
			if(m[buf[i]]){
				ops.push_back(get_val(buf[i]));
			}
			else if(buf[i]=='N'){
				ops.back() = !ops.back();
			}
			else {
				int op1 = ops.back();
				ops.pop_back();
				int op2 = ops.back();
				ops.pop_back();
				int tmp = get_res(buf[i],op1,op2);
				ops.push_back(tmp);
			}
		}
		if(ops[0]==0){
			printf("not\n");
			return;
		}
	}
	printf("tautology\n");
	
}

int main(){
	//CApNpKpNp
	while(true){
		scanf("%s",buf);
		if(buf[0]=='0')
			return 0;
		process();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值