Codeup二叉树的遍历:复原二叉树

题目描述

小明在做数据结构的作业,其中一题是给你一棵二叉树的前序遍历和中序遍历结果,要求你写出这棵二叉树的后序遍历结果。

输入

输入包含多组测试数据。每组输入包含两个字符串,分别表示二叉树的前序遍历和中序遍历结果。每个字符串由不重复的大写字母组成。

输出

对于每组输入,输出对应的二叉树的后续遍历结果。

样例输入

DBACEGF ABCDEFG
BCAD CBAD

样例输出

ACBFGED
CDAB

#include<bits/stdc++.h>
using namespace std;
const int maxn=50;
struct node{
	char data;
	node* lchild;
	node* rchild;
};
string pre,in,post;

node* create(int prel,int prer,int inl,int inr){
	if(prel>prer){
		return NULL;
	}
	node *root=new node;
	root->data=pre[prel];
	int k;
	for(k=inl;k<=inr;k++){
		if(in[k]==pre[prel]){
			break;
		}
	}
	int numleft=k-inl;//左子树的节点个数
	root->lchild=create(prel+1,prel+numleft,inl,k-1);//返回左子树的根节点地址 
	root->rchild=create(prel+numleft+1,prer,k+1,inr);//返回右子树的根节点地址 
	return root; //返回根节点地址 
}
void postorder(node *root){
	if(root==NULL) return;
	postorder(root->lchild);
	postorder(root->rchild);
	printf("%c",root->data);	
}
int main(){
	while(cin>>pre>>in){
		node* root=create(0,pre.size()-1,0,in.size()-1);
		postorder(root);
		cout<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值