Max Sum of Max-K-sub-sequence

Problem Description

Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. 
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.

Sample Input

4
6 3
6 -1 2 -6 5 -5
6 4
6 -1 2 -6 5 -5
6 3
-1 2 -6 5 -5 6
6 6
-1 -1 -1 -1 -1 -1

Sample Output

7 1 3
7 1 3
7 6 2
-1 1 1

Author

NotOnlySuccess@HDU

Source

HDOJ Monthly Contest – 2010.06.05
纠结了一天的题目,一开始想错了。。以为直接搞就出来了。。后来想通了之后是错的之后采用单调队列完美解决!
ans=max(sum[i]-min(sum[i-k]) 采用单调队列维护在区间[i-k,i-1]的sum值单调就行了
单调队列十分强大!
#include<iostream>
#include<algorithm>
using namespace std;
#define N 200020
#define inf 0xfffffff
struct node
{
int index,num;
};
node dia[N];
int q[2*N],sum[N];
int main()
{
int i,j,T,head,tail;
int n,k;
scanf("%d",&T);
while(T --)
{
int s,e,ans=-inf;
sum[0]=0;
scanf("%d%d",&n,&k);
for(i=1;i<=n;i++)
{
scanf("%d",&dia[i].num);
if(ans<dia[i].num)
{
ans=dia[i].num;
s=i;
e=i;
}
dia[i].index=i;
sum[i]=sum[i-1]+dia[i].num;
}
for(i=1;i<k;i++)
{
dia[i+n].index=i+n;
dia[i+n].num=dia[i].num;
sum[i+n]=sum[i+n-1]+dia[i+n].num;
}
dia[0].index=0;
dia[0].num=0;
head=N;
tail=N;
q[++head]=0;
int temp;
for(i=1;i<=n+k-1;i++)
{
temp=sum[i];
if(i<=k&&ans<temp)
{
ans=temp;
s=1;
e=i;
}
while(dia[q[head]].index<i-k)
head--;
temp-=sum[q[head]];
if(ans<temp)
{
ans=temp;
s=q[head]+1;
e=i;
}
while(tail<head&&(sum[q[tail+1]]>sum[i] || q[tail+1]<i-k) )
tail++;
q[tail--]=i;
}
cout<<ans<<" "<<s<<" "<<(e>n?e-n:e)<<endl;
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值