prime path.

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int f[10001],f1[10011];
int s[5],m,n;
struct node
{
    int x,y,z,f,g;
};
int qwe()
{
    queue<node> q;
    node a,b,c;
    int i,j,k;
    a.x=s[0];
    a.y=s[1];
    a.z=s[2];
    a.f=s[3];
    a.g=0;
    q.push(a);
    while(!q.empty())
    {
        b=q.front();
        q.pop();
        k=b.x*1000+b.y*100+b.z*10+b.f;
        if(k==n)
            return b.g;
        for(i=1; i<=9; i=i+2)
        {
            if(i!=b.f)
            {
                k=b.x*1000+b.y*100+b.z*10+i;
                if(f[k]==1&&f1[k]==0)
                {
                    c.x=b.x;
                    c.y=b.y;
                    c.z=b.z;
                    c.f=i;
                    c.g=b.g+1;
                    f1[k]=1;
                    q.push(c);
                }
            }
        }
        for(i=0; i<=9; i++)
        {
            if(i!=b.z)
            {
                k=b.x*1000+b.y*100+i*10+b.f;
                if(f[k]==1&&f1[k]==0)
                {
                    c.x=b.x;
                    c.y=b.y;
                    c.z=i;
                    c.f=b.f;
                    c.g=b.g+1;
                    f1[k]=1;
                    q.push(c);
                }
            }
        }
        for(i=0; i<=9; i++)
        {
            if(i!=b.y)
            {
                k=b.x*1000+i*100+b.z*10+b.f;
                if(f[k]==1&&f1[k]==0)
                {
                    c.x=b.x;
                    c.y=i;
                    c.z=b.z;
                    c.f=b.f;
                    c.g=b.g+1;
                    q.push(c);
                    f1[k]=1;
                }
            }
        }
        for(i=1; i<=9; i++)
        {
            if(i!=b.x)
            {
                k=i*1000+b.y*100+b.z*10+b.f;
                if(f[k]==1&&f1[k]==0)
                {
                    c.x=i;
                    c.y=b.y;
                    c.z=b.z;
                    c.f=b.f;
                    c.g=b.g+1;
                    f1[k]=1;
                    q.push(c);
                }
            }
        }
    }
    return -1;
}
int main()
{
    int i,j,g;
    for(i=1000; i<10000; i++)
    {
        g=0;
        for(j=2; j<=sqrt(i); j++)
            if(i%j==0)
            {
                g=1;
                break;
            }
        if(g==0)
            f[i]=1;
    }
    int w;
    scanf("%d",&w);
    while(w--)
    {
        memset(f1,0,sizeof(f1));
        int l=3,sum=-1;
        scanf("%d%d",&m,&n);
        f1[m]=1;
        if(m==n)
        {
            printf("0\n");
            continue;
        }
        while(m)
        {
            s[l--]=m%10;
            m=m/10;
        }
        sum=qwe();
        if(sum==-1)
            printf("Impossible\n");
        else
            printf("%d\n",sum);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值