Drying (二分)

Drying
It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.
Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.
There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.
Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).
The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.

sample input #1
3
2 3 9
5
sample output #1
3

sample input #2
3
2 3 6
5
sample output #2
2
大意:n件衣服,自然风干每分钟可以晾干1单位的水;用烘干机的话可以每分钟烘干k单位的水,但是一次只能烘干一件,问最小多少分钟可以烘干所有的衣服。
思路:通过二分查找,mid为我们尝试的答案,当k=1是,答案应该为数组里的最大值。当k!=1时,我们可以发现,比mid小或等于mid的衣服可以直接忽略,剩下的衣服也可以都减去mid,然后将剩下的也就是b[i]与k进行运算,计算出需要多少时间。将一件衣服弄干,共需要t分钟,烘干的时间为s,则自然干的时间为(t-s),将衣服弄干的条件即为ks+(t-s)>= a [i],化简为:s(k-1)+t >= a[i],因此s = (a[i]-t)/(k-1)。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
long long a[1001000],k,n;
bool find(long long t){
    long long sum=0,i;
    for(i=0; i<n; i++){
        if(a[i]>t)
            sum+=1.0*(a[i]-t)/(k-1);
    }
    if(sum>t)   return 0;
    else        return 1;
}
int main(){

    while(scanf("%lld",&n)!=EOF){
        long long i,maxx=0;
        for(i=0; i<n; i++){
            scanf("%lld",&a[i]);
            maxx=max(maxx,a[i]);
        }
        scanf("%lld",&k);
        if(k==1){
            printf("%lld\n",maxx);
            continue;
        }
        long long righ=maxx,left=1;
        while(left<=righ){
            int mid=(left+righ)/2;
            if(find(mid))
                righ=mid-1;
            else
                left=mid+1;
        }
        printf("%lld\n",left);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值