http://poj.org/problem?id=1463
Strategic game
Time Limit: 2000MS | Memory Limit: 10000K | |
Total Submissions: 6413 | Accepted: 2973 |
Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?
Your program should find the minimum number of soldiers that Bob has to put for a given tree.
For example for the tree:
the solution is one soldier ( at the node 1).
Your program should find the minimum number of soldiers that Bob has to put for a given tree.
For example for the tree:
the solution is one soldier ( at the node 1).
Input
The input contains several data sets in text format. Each data set represents a tree with the following description:
The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.
- the number of nodes
- the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
or
node_identifier:(0)
The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.
Output
The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:
Sample Input
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
Sample Output
1 2
Source
就是求树的最小点覆盖。
树形dp做法是dp[i][0]表示以i为根的子树i没有放被覆盖的最小点数,dp[i][1]表示放在i。
dp[i][0]=sum(dp[j][1]) 该点不放它的儿子必须都放
dp[i][1]+=sum(min(dp[j][0],dp[j][1])); 该点放了儿子放不放都可,初始化dp[i][1]=1;
很简单!
/**
* @author neko01
*/
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb push_back
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
#define dbg(a) printf("%d\n",a)
typedef pair<int,int> pp;
const double eps=1e-9;
const double pi=acos(-1.0);
const int INF=0x3f3f3f3f;
const LL inf=(((LL)1)<<61)+5;
const int N=1505;
vector<int>g[N];
int dp[N][2];
void dfs(int u,int fa)
{
dp[u][1]=1;
dp[u][0]=0;
for(int i=0;i<g[u].size();i++)
{
int v=g[u][i];
if(v!=fa)
{
dfs(v,u);
dp[u][1]+=min(dp[v][1],dp[v][0]);
dp[u][0]+=dp[v][1];
}
}
}
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<=n;i++)
g[i].clear();
for(int i=0;i<n;i++)
{
int u,v,x;
scanf("%d:(%d)",&u,&x);
while(x--)
{
scanf("%d",&v);
g[u].pb(v);
g[v].pb(u);
}
}
dfs(0,-1);
printf("%d\n",min(dp[0][0],dp[0][1]));
}
return 0;
}
也可以直接求二分图最小点覆盖!直接匈牙利233
/**
* @author neko01
*/
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb push_back
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
#define dbg(a) printf("%d\n",a)
typedef pair<int,int> pp;
const double eps=1e-9;
const double pi=acos(-1.0);
const int INF=0x3f3f3f3f;
const LL inf=(((LL)1)<<61)+5;
const int N=1505;
vector<int>g[N];
int cx[N];
int cy[N];
bool vis[N];
int n1,n2;
bool dfs(int u)
{
for(int i=0;i<g[u].size();i++)
{
int v=g[u][i];
if(!vis[v])
{
vis[v]=true;
if(cy[v]==-1||dfs(cy[v]))
{
cy[v]=u;
cx[u]=v;
return true;
}
}
}
return false;
}
int hungary()
{
clr1(cx);
clr1(cy);
int ans=0;
for(int i=0;i<n1;i++)
{
if(cx[i]==-1)
{
clr(vis);
if(dfs(i))
ans++;
}
}
return ans;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<=n;i++)
g[i].clear();
for(int i=0;i<n;i++)
{
int u,v,x;
scanf("%d:(%d)",&u,&x);
while(x--)
{
scanf("%d",&v);
g[u].pb(v);
g[v].pb(u);
}
}
n1=n2=n;
printf("%d\n",hungary()/2);
}
return 0;
}