Hdu6024 dp(类01背包)

Problem Description
HDU’s  n  classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these  n  classrooms.

The total cost consists of two parts. Building a candy shop at classroom  i  would have some cost  ci . For every classroom  P  without any candy shop, then the distance between  P  and the rightmost classroom with a candy shop on  P 's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
 

Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer  n(1n3000) , denoting the number of the classrooms.
In the following  n  lines, each line contains two integers  xi,ci(109xi,ci109) , denoting the coordinate of the  i -th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
 

Output
For each test case, print a single line containing an integer, denoting the minimal cost.
 

Sample Input
  
  
3 1 2 2 3 3 4 4 1 7 3 1 5 10 6 1
 

Sample Output
  
  
5 11
#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
const ll INF=1e18;
struct node{
	int c;
	int d;
}a[3030];
ll dis[3010][3010];
ll dp[3010][5];
bool cmp(node n1,node n2)
{
	return n1.d<n2.d;
}
int main()
{
	int n;	
	while(scanf("%d",&n)!=EOF)
	{	
		for(int i=0;i<n;i++)
			scanf("%d%d",&a[i].d,&a[i].c);
		sort(a,a+n,cmp);
		int i,j;
		for(i=0;i<n;i++)
		{
			dis[i][i]=0;
			for(j=i+1;j<n;j++)
			{
				dis[i][j]=dis[i][j-1]+a[j].d-a[i].d;
			}
		}
		for(int i=0;i<n;i++)
		{
			dp[i][0]=dp[i][1]=INF;	
		} 
		
		dp[0][1]=a[0].c;
		for(i=1;i<n;i++)
		{
			dp[i][1]=min(dp[i-1][0],dp[i-1][1])+a[i].c;
			for(j=i-1;j>=0;j--)
			{
				dp[i][0]=min(dp[i][0],dp[j][1]+dis[j][i]);
			}
		}
	printf("%lld\n",min(dp[n-1][0],dp[n-1][1]));
  }
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值