1133 Splitting A Linked List (25分)--PAT甲级真题

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5) which is the total number of nodes, and a positive K (≤103). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer in
[−10​5,105], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:
For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

题目大意:给你一个链表,以及一个正整数K;之后变换列表中元素的位置,使得小于等于0的数字都在大于0的数字左边,使得所有小于等于K的数字都在大于K的数字的左边;各元素保持相对位置不变

分析:给出的数据并不都一定在链表上,所以处理输入的时候,要根据头结点的地址从头到尾再遍历一遍,找出链表上所有的数并且放入vector,并且记录他们输入的顺序用index标记;之后根据要求给vector中的数字排序,从前往后输出排序之后的链表;

排序规则:如果数字a,b都小于等于0,index小的在前;如果a,b都大于0并且小于等于K,index小的在前;如果a,b都大于K,index小的在前;否则,a,b中值小的在前;

#include <iostream>
#include<vector>
#include<queue>
#include<algorithm> 
using namespace std; 
struct Node{
	int addr, d, index;
}; 
int dat[100001],nex[100001]; 
int first, N, K;
bool cmp(Node A, Node B){
	if (A.d < 0 && B.d < 0)
		return A.index < B.index;
	else if ((A.d >= 0 && A.d <= K) && (B.d >= 0 && B.d <= K))
		return  A.index < B.index;
	else if (A.d > K&&B.d > K)
		return  A.index < B.index;
	else
		return A.d < B.d; 
} 
int main(){ 
	vector<Node>V;
	scanf("%d%d%d", &first, &N, &K);  
	for (int i = 0; i < N; i++){
		int addr;
		scanf("%d", &addr); 
		scanf("%d%d", &dat[addr], &nex[addr]);
	} 
	int index = 0;
	while (first != -1){
		Node tmp;
		tmp.addr = first;
		tmp.d = dat[first];
		tmp.index = index++;
		first = nex[first]; 
		V.push_back(tmp);
	} 
	sort(V.begin(), V.end(), cmp);   
	for(int i =0; i<V.size()-1; i++) 
		printf("%05d %d %05d\n", V[i].addr, V[i].d, V[i+1].addr); 
	printf("%05d %d %d\n", V[V.size() - 1].addr, V[V.size() - 1].d, -1);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值