poj 1273 Drainage Ditches 网络流最大流入门 ford-fulkerson

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 70072 Accepted: 27200

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source


题意描述:
现在有m个池塘(从1到m开始编号,1为源点,m为汇点),及n条水渠,给出这n条水渠所连接的池塘和所能流过的水量,求水渠中所能流过的水的最大容量.一道基础的最大流题目。

对于网络流最大流ford-fulkerson算法,如何理解呢?

先考虑这样的贪心算法:


但事实上有更优的路线如下:


贪心算法得到的结果是10,而上图得到的结果是11。为了找出二者的区别,不妨来看看它们的流量的差。


通过对流量的差的观察我们发现,我们可以将原先得到的流给推回去,而得到新的流。因此,可以试着在之前的贪心算法加上这一操作,将算法做出如下改进。


下面是此题的代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <functional>
using namespace std;
const int INF = 0x3f3f3f3f;
const int MAXN = 2e2 + 10;
struct edge {
    int t, c, rev;
    edge(int _t, int _c, int _rev) {
        t = _t; c = _c; rev = _rev;
    }
};
int n, m;
vector<edge> G[MAXN];
bool vis[MAXN];

int dfs(int v, int t, int f) {
    if (v == t) return f;
    vis[v] = true;
    for (int i = 0; i < G[v].size(); ++i) {
        edge& e = G[v][i];
        if (!vis[e.t] && e.c > 0) {
            int d = dfs(e.t, t, min(f, e.c));
            if (d > 0) {
                e.c -= d;
                G[e.t][e.rev].c += d;
                return d;
            }
        }
    }
    return 0;
}

int max_flow(int s, int t) {
    int flow = 0;
    for (;;) {
        memset(vis, 0, sizeof(vis));
        int add = dfs(s, t, INF);
        if (add == 0) return flow;
        flow += add;
    }
}

int main() {
#ifdef NIGHT_13
    freopen("in.txt", "r", stdin);
#endif
    while (scanf("%d%d", &n, &m) != EOF) {
        for (int i = 0; i <= m; ++i) {
            G[i].clear();
        }
        for (int i = 0, v, t, c; i < n; ++i) {
            scanf("%d%d%d", &v, &t, &c);
            G[v].push_back(edge(t, c, G[t].size()));
            G[t].push_back(edge(v, 0, G[v].size() - 1));
        }
        printf("%d\n", max_flow(1, m));
    }
    return 0;
}

参考资料:《挑战程序设计竞赛》巫泽俊译

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值