poj1094 Sorting It All Out 拓扑排序

Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33337 Accepted: 11614

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

拓扑排序算法思想:

(1) 从有向图中选取一个没有前驱(即入度为0)的顶点,并保存到队列里;

(2) 从有向图中删去此顶点以及所有以它为尾的弧;

(3) 重复上述两步,直至图空,或者图不空但找不到无前驱的顶点为止,最后输出队列。


#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <queue>
#include <algorithm>
#include <map>
#include <stack>
using namespace std;

const int MAXN = 26;
const int INF = 0x3f3f3f3f;
int n, m;
int inDegree[MAXN];
bool G[MAXN][MAXN];
char que[MAXN + 1];

int TopoSort() {
    memset(que, 0, sizeof(que));
    int ind[MAXN];
    memcpy(ind, inDegree, sizeof inDegree);
    int flag = 1, cnt = 0;

    for (int i = 0; i < n; ++i) {
        int zero = 0, pos;
        for (int j = 0; j < n; ++j) {
            if (ind[j] == 0) {
                ++zero;
                pos = j;
            }
        }
        if (zero == 0) {
            return 0;
        }
        if (zero > 1) {
            flag = -1;
        }
        que[cnt++] = pos + 'A';
        ind[pos] = -1;
        for (int j = 0; j < n; ++j) {
            if (G[pos][j]) {
                --ind[j];
            }
        }
    }
    return flag;
}

int main() {
#ifdef NIGHT_13
    freopen("in.txt", "r", stdin);
#endif
    while (scanf("%d%d%*c", &n, &m), n + m) {
        memset(inDegree, 0, sizeof inDegree);
        memset(G, 0, sizeof G);

        int sign = -1;
        for (int i = 1; i <= m; ++i) {
            char x, y;
            scanf("%c%*c%c%*c", &x, &y);
            if (sign != -1) continue;

            x -= 'A', y -= 'A';
            G[x][y] = true;
            inDegree[y]++;

            sign = TopoSort();
            if (sign == 1) {
                printf("Sorted sequence determined after %d relations: %s.\n", i, que);
            } else if (sign == 0) {
                printf("Inconsistency found after %d relations.\n", i);
            }
        }
        if (sign == -1) {
            printf("Sorted sequence cannot be determined.\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值