BestCoder Round #33(zhx's contest-快速乘法)

zhx's contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1366    Accepted Submission(s): 437


Problem Description
As one of the most powerful brushes, zhx is required to give his juniors n problems.
zhx thinks the ith problem's difficulty is i . He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1..ai are monotone decreasing or monotone increasing.
2: ai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p .
 

Input
Multiply test cases(less than 1000 ). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. ( 1n,p1018 )
 

Output
For each test case, output a single line indicating the answer.
 

Sample Input
  
  
2 233 3 5
 

Sample Output
  
  
2 1
Hint
In the first case, both sequence {1, 2} and {2, 1} are legal. In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5193  5192  5191  5190  5189 
 

本题使用快速乘法和快速幂

其中,快速乘法就是把乘数a的2进制(100010101)2 这样的数

分解成(2^p0+2^p1+...)*b=2^p0*b+2^p1*b ....  然后算

本题快速幂和快速乘法均用栈。
PS:由于忘了在sub()处%F 又WA又T的





#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define Forpiter(x) for(int &p=iter[x];p;p=next[p])  
typedef __int64 ll;
ll n,F;
ll add(ll a,ll b){return (a+b)%F;}
void upd(ll &a,ll b){a=(a%F+b%F)%F;}
ll mul(ll a,ll b) //c=a*b=a^l1+a^l2+...+a^l3 //把b改成2进制,各位分别相乘相加 
{
	ll c=0;
	while(b)
	{
		if (b&1) c=(c+a)%F; 
		a=(a+a)%F; 
		b>>=1; 
	}
	
	return c%F;
}
ll sub(ll a,ll b){if ((a-b)<0) return (a-b+F)%F;return (a-b)%F;}
ll pow2(ll a,ll b)
{
	if (b==1) return a%F;
	if (b==0) return 1%F;
	
	ll ret=1;
	while (b)
	{
		if (b&1) ret=mul(ret,a);
		a=mul(a,a);
		b>>=1;
	} 
	return ret%F;
	
}
int main()
{
//	freopen("zhx's contest.in","r",stdin);
	
	while(scanf("%I64d%I64d",&n,&F)==2)
	{
		if (n==1) printf("%I64d\n",1%F);
		else printf("%I64d\n",sub(pow2(2%F,n),2));
	}
	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值