1031 Hello World for U(模拟题+memset)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1 characters, then left to right along the bottom line with n​2 characters, and finally bottom-up along the vertical line with n3characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n​1=n​3=max { k | k≤n​2 for all 3≤n2≤N } withn1​​ +n​2+n​3−2=N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:(下面这个格式有点不对,自己知道就行了)

h !
e d
l l
lowor

//题目的意思是,n1和n3是从顶到最后一行(因为表达式里是减去2了的),n2也是包括头尾两个字符的 
#include<iostream>
#include<cstring>
using namespace std;
/*
本题思路:其实找对思路了真的很简单。你想,n1和n3要<=n2并且n1=n3。所以,假设初始情况是n1=n2=n3=3,那么:
		  放入1个字符是要先放在n2的,2个字符也要放在n2,3个字符则n1,n2,n3各一个,4个字符则n1=n3=1,n2=2...
		  多举些例子,依次类推,发现关系式就是n1=n3=n/3,n2=n/3+n%3。 
		这个关系式这么就可以这样理解:新加入的数总是要n1,n2,n3各放一个,然后多余的放入n2。这样就能保证n1,n3不超过n2同时足够大。 
*/
int main(){
	string s;
	cin>>s;
	int len=s.size()+2;
	int n1=len/3,n3=len/3,n2=len/3+len%3;
	char block[50][50];
	memset(block,' ',sizeof(block));//memset一定别忘了怎么用的 
	int index=0;
	for(int i=0;i<n1;i++){
		block[i][0]=s[index++];
	}
	for(int i=1;i<n2-1;i++){
		block[n1-1][i]=s[index++];
	}
	for(int i=n3-1;i>=0;i--){
		block[i][n2-1]=s[index++];
	}
	for(int i=0;i<n1;i++){
		for(int j=0;j<n2;j++){
			cout<<block[i][j];
		}
		cout<<endl;
	}
	return 0;	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值