HDU 3709 —— Balanced Number(数位dp)

Balanced Number

Time Limit:5000MS     Memory Limit:65535KB     64bit IO Format:%I64d & %I64u

 

Description

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job 
to calculate the number of balanced numbers in a given range [x, y].

 

Input

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).

 

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.

 

Sample Input

2

0 9

7604 24324

 

Sample Output

10

897

 

思路: 简单的按照题目的意思,每次计算出 轴 前段的和 与 轴后段的和 然后比较, 是不可能 的,因为这样的话我们就需要一个四维的dp数组,dp[pos][pivot][sumfront][sumrear], 而很明显, sumfront,sumrear 需要的大小 在1710左。对于一个思维数组。出现两个1710的大小,已经很大很大了。 所以我们设定一个三维dp数组, dp[pos][pivot][sum],  表示第pos位,轴在pivot, 前与后的和为sum, 计算的时候, 前段的和 是正 , 后段的和是负  , 如果最终 和为 0 , 则这个数平衡。

对于dp数组:  当我们没有限制,可以任意填写数字时(limit=0),如果剩下的等待填写的位数相同(pos),重心pivot相同(计算力矩的公式一模一样),当前力矩torque(当前这一位前面也填写了若干位)也相同,则可以断定:即使我之前填写的数字是不一样的,最终填写完全后的平衡数的个数会是相同的!

因此,dp[pos][pivot][torque]的定义是正确的!

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

typedef long long LL;
int a[20], sum[20];
LL dp[20][20][1710];
int len;

LL dfs(int u, int pivot, int torque, bool limit)
{
    if(u < 1)    return torque == 0;
    
    if(!limit && dp[u][pivot][torque] != -1)    return dp[u][pivot][torque];
    
    int maxn = limit ? a[u] : 9;
    LL ret = 0;
    int newT;
    for(int i=0; i<=maxn; i++) {
        newT = torque+(u-pivot)*i;
        if(newT >= 0)
            ret += dfs(u-1, pivot, newT, limit&&i==maxn);
    }
    if(!limit)    dp[u][pivot][torque] = ret;
    return ret;
}

LL f(LL x)
{
    len=0;
    while(x) {
        a[++len] = x%10;
        x /= 10;
    }
    LL ret = 0;
    for(int i=1; i<=len; i++) {
        ret += dfs(len, i, 0, 1);
    }
    return ret-len+1;
}

int main ()
{
    int T;
    LL x, y;
    scanf("%d", &T);
    memset(dp, -1, sizeof(dp));
    while(T--) {
        scanf("%lld%lld", &x, &y);
        printf("%lld\n", f(y) - f(x-1));
    }
    
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值