CSU 1010 water drinking

1010: Water Drinking

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 224  Solved: 72
[ Submit][ Status][ Web Board]

Description

The Happy Desert is full of sands. There is only a kind of animal called camel living on the Happy Desert. ‘Cause they live here, they need water here. Fortunately, they find a pond which is full of water in the east corner of the desert. Though small, but enough. However, they still need to stand in lines to drink the water in the pond.

Now we mark the pond with number 0, and each of the camels with a specific number, starting from 1. And we use a pair of number to show the two adjacent camels, in which the former number is closer to the pond. There may be more than one lines starting from the pond and ending in a certain camel, but each line is always straight and has no forks.

Input

There’re multiple test cases. In each case, there is a number N (1≤N≤100000) followed by N lines of number pairs presenting the proximate two camels. There are 99999 camels at most.

Output

For each test case, output the camel’s number who is standing in the last position of its line but is closest to the pond. If there are more than one answer, output the one with the minimal number.

Sample Input

1
0 1
5
0 2
0 1
1 4
2 3
3 5
5
1 3
0 2
0 1
0 4
4 5

Sample Output

1
4 
2
本题考查的是并查集。可是现在还不懂那个,就用的邻接链表图,虽然很笨,但索性最后AC了。。。
需要注意的是RUNTIME ERROR:
   (1)不能用while(true)代替while(scan.hasNext())
   (2)Java好像不能像C/C++那样提前定义足够大的数组,要尽量根据读入参数确定数组长度
import java.util.ArrayList;
import java.util.Scanner;

public class Main {
	private LinkNode first;
	public Main(){
	}
	public Main(int a){
		first=new LinkNode();
		first.root=a;
	}
	public void Insert(int a){
		if(first.next==null){
			first.next=new LinkNode(a);
		}
		else{
			LinkNode temp=first.next;
			first.next=new LinkNode(a);
			first.next.next=temp;
		}
	}
	public static int min(int[] a){
		int m;
		m=a[0];
		for(int temp:a){
			if(temp<m){
				m=temp;
			}
		}
		return m;
	}
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner scan=new Scanner(System.in);
		while(scan.hasNext()){
			int times=scan.nextInt();
			Main[] link=new Main[times+1];
			for(int i=0;i<link.length;i++){
				link[i]=new Main(i);
			}
			for(int i=0;i<times;i++){
				int a=scan.nextInt();
				int b=scan.nextInt();
				link[a].Insert(b);
			}
			ArrayList<Integer> num=new ArrayList<Integer>();
			LinkNode temp=link[0].first;
			while(temp.next!=null){
				num.add(temp.next.root);
				temp=temp.next;
			}
			int len=num.size();
			int[] endnum=new int[len];
			int[] count=new int[len];
			for(int i=0;i<len;i++){
				int f=num.get(i);
				LinkNode t=link[f].first;
				int countindex=0;
				while(t.next!=null){
					t=link[t.next.root].first;
					countindex++;
				}
				endnum[i]=t.root;
				count[i]=countindex;
			}
			int closest=min(count);
			ArrayList<Integer> c=new ArrayList<Integer>();
			for(int i=0;i<len;i++){
				if(count[i]==closest){
					c.add(endnum[i]);
				}
			}
			int clen=c.size();
			int[] result=new int[clen];
			for(int i=0;i<clen;i++){
				result[i]=c.get(i);
			}
			System.out.println(min(result));
		}
	}
}
class LinkNode{
	public int root;
	public LinkNode next;
	public LinkNode(){
	}
	public LinkNode(int a){
		root=a;
		next=null;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值