HDU1711 Number Sequence【机智 or KMP模板】

Number Sequence

Time Limit: 5000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

Source


大家都在看模板,而我没有模板,iwi,一值超时,哎,然而在每次判断时先判断下首尾是否相等就可以降低时间复杂度,区别就是 Time Limit Exceed和1076MS
方法一:
#include<stdio.h>
#include<string.h>
using namespace std;
int a[1000050],b[10050];
int main()
{
    int t,n,m,i,j,bj;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        scanf("%d",&m);
        for(i=1; i<=n; i++)
            scanf("%d",&a[i]);
        for(i=0; i<m; i++)
            scanf("%d",&b[i]);

        for(i=1; i<=n-m+1; i++)//a数组
        {
            bj=1;
            if(a[i]==b[0]&&a[i+m-1]==b[m-1])//判首尾
            {
                bj=0;
                for(j=0; j<m; j++)//匹配
                    if(a[i+j]!=b[j])
                    {
                        bj=1;
                        break;
                    }
                if(bj==0)
                {
                    printf("%d\n",i);
                    break;
                }
            }
        }
        if(bj==1)
            printf("-1\n");
    }

}

f方法二KMP:
//引自kuangbin
#include<stdio.h>
#include<string.h>
int next[1000010];
int b[1000010];
int a[10010];
int ans;
//next[]的含义:x[i-next[i]...i-1]=x[0...next[i]-1]
//next[i]为满足x[i-z...i-1]=x[0...z-1]的最大z值(就是x的自身匹配)
void kmp_pre(int x[],int m,int next[])
{
    int i,j;
    j=next[0]=-1;
    i=0;
    while(i<m)
    {
        while(-1!=j&&x[i]!=x[j]) j=next[j];
        next[++i]=++j;
    }
}
int KMP(int x[],int m,int y[],int n)
{//x是模式串,y是主串
    int i,j;
    int ans=-1;
    kmp_pre(x,m,next);
    i=j=0;
    while(i<n)
    {
        while(-1!=j&&y[i]!=x[j]) j=next[j];
        i++;j++;
        if(j>=m)
        {
            ans=i-m+1;break;
            j=next[j];

        }
    }
    return ans;

}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        scanf("%d",&b[i]);
        for(int i=0;i<m;i++)
        scanf("%d",&a[i]);
        int x=-1;
       x=KMP(a,m,b,n);
        printf("%d\n",x);
    }
}


1076 MS
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值