Subsequence
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 12187 | Accepted: 5096 |
Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2 10 15 5 1 3 5 10 7 4 9 2 8 5 11 1 2 3 4 5
Sample Output
2 3
Source
Southeastern Europe 2006
我的AC代码:O(n)
On<挑战>的代码:这是别人的思想欸, 挺有意思~O(nlogn)
我的AC代码:O(n)
#include <iostream>
#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <utility>
#include <algorithm>
//#define LOCA
using namespace std;
const int maxn = 1e5+50;
int a[maxn];
int main()
{
#ifdef LOCA
freopen("AAA.txt", "r", stdin);
#endif // LOCA
int t, n, sum, m, ans;
cin >> t;
while (t--)
{
ans = maxn;
memset(a, 0, sizeof(a));
cin >> n >> m;
for (int i=0; i<n; i++)
{
cin >> a[i];
}
sum = a[0];
int first = 1;
int last = 0;
while (1)
{
if (sum < m && first < n)
{
sum += a[first++];
}
while (sum >= m && last < n)
{
ans = min (ans, first-last);
sum -= a[last++];
}
if (last == n || (sum < m && first == n))
{
break;
}
}
if (ans == maxn)
{
cout << "0" << endl;
}
else
{
cout << ans << endl;
}
}
return 0;
}
On<挑战>的代码:这是别人的思想欸, 挺有意思~O(nlogn)
#include <iostream>
#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <utility>
#include <algorithm>
using namespace std;
const int maxn = 1e5+50;
int sum[maxn], a[maxn];
int t, n, S;
void solve()
{
for (int i=0; i<n; i++)
{
sum[i+1] = sum[i] + a[i];
}
if (sum[n] < S)
{
cout << "0" << endl;
return ;
}
int res = n;
for (int s=0; sum[s]+S<=sum[n]; s++)
{
int t = lower_bound(sum+s, sum+n, sum[s]+S) - sum;
res = min (res, t-s);
}
cout << res << endl;
}
int main()
{
cin >> t;
while (t--)
{
memset(a, 0, sizeof(a));
memset(sum, 0, sizeof(sum));
cin >> n >> S;
for (int i=0; i<n; i++)
{
cin >> a[i];
}
solve();
}
return 0;
}
YUANLAI写完一道题后看看别人的思想也是一件很有意思的事情的说~~