A Simple Problem with Integers POJ - 3468 (线段树区间修改求和*)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

 

#include <algorithm>
#include <cstdio>

using namespace std;

const int N = 1e6 + 7;

struct Tree {
	int l, r, lazy;
	long long sum;
};

struct Tree tree[N];
long long a[N];

void pushup (int rt) {
	//printf ("pushup!\n");
	tree[rt].sum = tree[rt << 1].sum + tree[rt << 1 | 1].sum;
}

void build (int l, int r, int rt) {
	
	tree[rt].l = l, tree[rt].r = r, tree[rt].lazy = 0, tree[rt].sum = 0;
	if (l == r) {
		tree[rt].sum = a[l];
		return;
	}
	int mid = (l + r) >> 1;
	build (l, mid, rt << 1);
	build (mid + 1, r, rt << 1 | 1);
	pushup (rt);
	
}

void pushdown (int rt) {
	
	//printf ("pushdown!\n");
	int mid = (tree[rt].l + tree[rt].r) >> 1;
	tree[rt << 1].sum += (long long)tree[rt].lazy * (mid - tree[rt].l + 1); // +=
	tree[rt << 1 | 1].sum += (long long)tree[rt].lazy * (tree[rt].r - mid);
	tree[rt << 1].lazy += tree[rt].lazy; // +=
	tree[rt << 1 | 1].lazy += tree[rt].lazy;
	tree[rt].lazy = 0;
	
}

void update (int l, int r, int val, int rt) {
	
	//printf ("update!\n");
	if (tree[rt].l == l && tree[rt].r == r) {
		tree[rt].sum += (long long)(val * (r - l + 1));
		tree[rt].lazy += val; // +=
		return;
	}
	if (tree[rt].lazy != 0) pushdown (rt);
	int mid = (tree[rt].l + tree[rt].r) >> 1;
	if (r <= mid) update (l, r, val, rt << 1);
	else if (l > mid) update (l, r, val, rt << 1 | 1);
	else {
		update (l, mid, val, rt << 1);
		update (mid + 1, r, val, rt << 1 | 1);
	}
	pushup (rt);
	
}

long long query (int l, int r, int rt) {
	
	//printf ("%d %d %d %d %lld\n", l, r, tree[rt].l, tree[rt].r, tree[rt].sum);
	if (tree[rt].l == l && tree[rt].r == r) {
		return tree[rt].sum;
	}
	if (tree[rt].lazy != 0) pushdown (rt);
	int mid = (tree[rt].l + tree[rt].r) >> 1;
	if (r <= mid) return query (l, r, rt << 1);
	else if (l > mid) return query (l, r, rt << 1 | 1);
	else return (long long)query (l, mid, rt << 1) + query (mid + 1, r, rt << 1 | 1);
	
}



int main ()  {
	
	int n, q;
	while (~scanf ("%d %d", &n, &q)) {
		for (int i = 1; i <= n; ++i)  {
		scanf ("%lld", &a[i]);
		}
		build (1, n, 1);
		char op;
		int x, y, z;
		while (q--) {
			scanf (" %c %d %d", &op, &x, &y);
			if (op == 'C') {
				scanf ("%d", &z);
				update (x, y, z, 1);
			} else {
				printf ("%lld\n", query (x, y, 1));
			}
		}
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值