Courses HDU - 1083 (HK)

Courses

 HDU - 1083 

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

. every student in the committee represents a different course (a student can represent a course if he/she visits that course) 

. each course has a representative in the committee 

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student1 1 Student1 2 ... Student1 Count1 
Count2 Student2 1 Student2 2 ... Student2 Count2 
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 

There are no blank lines between consecutive sets of data. Input data are correct. 

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line. 

An example of program input and output:

Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Output

YES
NO 

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO 
#include <algorithm>
#include <iostream>
#include <cstring>
#include <string>
#include <queue>
#include <cstdio>
#include <cmath>
#include <vector>
using namespace std;
const int N = 333;
const int INF = 0x3f3f3f3f;
int mx[N], my[N], dx[N], dy[N], in[N], dis;
vector<int> g[N];

bool bfs(int n) {
	
	memset(dx, -1, sizeof(dx));
	memset(dy, -1, sizeof(dy));
	queue<int> q;
	for (int i = 1; i <= n; ++i) {
		if (!mx[i]) dx[i] = 0, q.push(i); 
	}
	dis = INF;
	while (!q.empty()) {
		int u = q.front(); q.pop();
		if (dx[u] > dis) break;
		int m = g[u].size();
		for (int i = 0; i < m; ++i) {
			int v =  g[u][i];
			if (dy[v] == -1) {
				dy[v] = dx[u] + 1;
				if (!my[v]) dis = dy[v];
				else {
					dx[my[v]] = dy[v] + 1;
					q.push(my[v]);
				}
			}
		}
	}
	return dis != INF;
}

int dfs(int u) {
	int m = g[u].size();
	for (int i = 0; i < m; ++i) {
		int v = g[u][i];
		if (!in[v] && dy[v] == dx[u] + 1) {
			in[v] = 1;
			if (my[v] && dy[v] == dis) continue;
			if (!my[v] || dfs(my[v])) {
				my[v] = u;
				mx[u] = v;
				return 1;
			}
		}
	}
	return 0;
}

int main () {
	
	int t;
	scanf ("%d", &t);
	while (t--) {
		int p, n;
		scanf ("%d %d", &p, &n);
		for (int i = 1; i <= p; ++i) g[i].clear();
		for (int i = 1; i <= p; ++i) {
			int m, v;
			scanf ("%d", &m);
			for (int j = 1; j <= m; ++j) {
				scanf ("%d", &v);
				g[i].push_back(v);
			}
		}
		int ans = 0;
		memset(mx, 0, sizeof(mx));
		memset(my, 0, sizeof(my));
		while (bfs(p)) {
			memset(in, 0, sizeof(in));
			for (int i = 1; i <= p; ++i) {
				if (!mx[i] && dfs(i)) ++ans;
			}
		}
		if (ans != p) puts("NO");
		else puts("YES"); 
	}
	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值