hdu1074(状态压缩,DP,记录路径)

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8317    Accepted Submission(s): 3840


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
  
  
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
 
 
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.


第一次做数位dp的题,you一定的理解,因为2的幂特点,除了1,后边全是0,可以保存n次幂n种状态,学到了!!

#include<cstdio>
#include<map>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>

using namespace std;

const int INF=1<<15;
int vis[INF];
struct node1
{
    string str;
    int date;
    int cost;
}node[20];

struct node2
{
    int pre;
    int time;
    int cost;
}dp[INF];

void print(int x)
{
    int tmp=dp[x].pre^x;
    int num=0;
    while(tmp/2)
    {
        num++;
        tmp/=2;
    }
    if(dp[x].pre!=0)
    {
        print(dp[x].pre);
    }
    cout<<node[num].str<<endl;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>node[i].str>>node[i].date>>node[i].cost;
        }
        int maxx=(1<<n)-1;//<<运算符优先级没有-运算符高
        dp[0].time=0;
        dp[0].pre=-1;
        dp[0].cost=0;
        vis[0]=1;
        for(int i=0;i<maxx;i++)
        {
            for(int j=0;j<n;j++)
            {
                int temp=1<<j;
                if((temp&i)==0)
                {
                    int keep=temp|i;
                    dp[keep].time=dp[i].time+node[j].cost;
                    int reduce=dp[keep].time-node[j].date;
                    if(reduce<0)
                        reduce=0;
                    reduce+=dp[i].cost;
                    if(vis[keep]==0)
                    {
                        vis[keep]=1;
                        dp[keep].pre=i;
                        dp[keep].cost=reduce;
                    }
                    else
                    {
                        if(reduce<dp[keep].cost)
                        {
                            dp[keep].cost=reduce;
                            dp[keep].pre=i;
                        }
                        else if(reduce==dp[keep].cost)
                        {
                            if(dp[keep].pre>i)
                                dp[keep].pre=i;
                        }
                    }
                }
            }
        }
        printf("%d\n",dp[maxx].cost);
        print(maxx);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值