还是畅通工程贪心加并查集

Problem Description

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0

Sample Output

3 5

Hint

Hint Huge input, scanf is recommended.

Source

浙大计算机研究生复试上机考试-2006年

思路:讲路的长度放到一个数组,每一次取出最小值判断是否联通,联通的话就舍弃,否则就加上权重。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=10005;
struct Rode
{
    int s,e,w;
} a[maxn];
int pre[maxn];
int n,m;
int Find(int x)
{
    return pre[x]==x?x:pre[x]=Find(pre[x]);
}
bool cmp(Rode a,Rode b)
{
    return a.w<b.w;
}
int fun()
{
    int ans=0;
    for(int i=1; i<=n; i++)
        pre[i]=i;
    sort(a+1,a+m+1,cmp);
    for(int i=1; i<=m; i++)
    {
        int x=Find(a[i].s);
        int y=Find(a[i].e);
        if(x!=y)
        {
            ans+=a[i].w;
            pre[x]=y;
        }
    }
    return ans;
}
int main()
{
//    freopen("C:\\Users\\nuoyanli\\Desktop\\acminput.txt","r",stdin);
    while(cin>>n,n)
    {
        m=n*(n-1)/2;
        for(int i=1; i<=m; i++)
            cin>>a[i].s>>a[i].e>>a[i].w;
        cout<<fun()<<endl;
    }
    return 0;
}

 希望对读者有所帮助。(由于笔者技术有限如有错误欢迎评论区指正)  

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

nuoyanli

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值