Roads in the North(树的直径)

Roads in the North
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice.
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area.

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.
Input
Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.
Output
You are to output a single integer: the road distance between the two most remote villages in the area.
Sample Input
5 1 6
1 4 5
6 3 9
2 6 8
6 1 7
Sample Output

22



我真没看懂输入格式。。。
没运行就交了。。。结果还对了:纯套模板
[cpp] view plain copy print?
#include<cstdio>  
#include<cstring>  
#include<queue>  
#include<algorithm>  
using namespace std;  
const int MAXN = 300010;  
struct Edge{  
    int from,to,val,next;  
};  
Edge edge[MAXN*2];  
  
int head[MAXN];  
int edgenum;  
void init(){  
    memset(head,-1,sizeof(head));  
    edgenum=0;  
}  
  
void addEdge(int u,int v,int w)  
{  
    edge[edgenum].from=u;  
    edge[edgenum].to=v;  
    edge[edgenum].val=w;  
    edge[edgenum].next=head[u];  
    head[u]=edgenum++;  
}  
  
int ans;  
int longest;  
int dis[MAXN];  
bool vis[MAXN];  
void BFS(int x)  
{  
    memset(dis,0,sizeof(dis));  
    memset(vis,false,sizeof(vis));  
    queue<int> Q;  
    Q.push(x);  
    dis[x]=0;  
    vis[x]=false;  
    ans=0;  
    while(!Q.empty())  
    {  
        int u = Q.front();  
        Q.pop();  
        for(int i=head[u];i!=-1;i=edge[i].next){  
            int v = edge[i].to;  
            if(!vis[v]){  
                if(dis[v]<dis[u]+edge[i].val){  
                    dis[v]=dis[u]+edge[i].val;  
                    if(ans<dis[v]){  
                        ans=dis[v];  
                        longest=v;  
                    }  
                }  
                vis[v]=true;  
                Q.push(v);   
            }  
        }  
    }  
}  
  
int main()  
{  
    int a,b,c;  
    init();  
    while(scanf("%d%d%d",&a,&b,&c)!=EOF)  
    {  
        addEdge(a,b,c);  
        addEdge(b,a,c);  
    }BFS(1);    BFS(longest);  
    printf("%d\n",ans);  
    return 0;  
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值