hdoj Jam's math problem 5615 (数学十字相乘法)暴力

73 篇文章 0 订阅
25 篇文章 0 订阅

Jam's math problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 734    Accepted Submission(s): 346


Problem Description
Jam has a math problem. He just learned factorization.
He is trying to factorize   ax2+bx+c  into the form of   pqx2+(qk+mp)x+km=(px+k)(qx+m) .
He could only solve the problem in which p,q,m,k are positive numbers.
Please help him determine whether the expression could be factorized with p,q,m,k being postive.
 

Input
The first line is a number   T , means there are   T(1T100)  cases  

Each case has one line,the line has   3  numbers   a,b,c(1a,b,c100000000)
 

Output
You should output the "YES" or "NO".
 

Sample Input
  
  
2 1 6 5 1 6 4
 

Sample Output
  
  
YES NO
Hint
The first case turn $x^2+6*x+5$ into $(x+1)(x+5)$
问题描述
Jam有道数学题想向你请教一下,他刚刚学会因式分解比如说,x^2+6x+5=(x+1)(x+5)x2+6x+5=(x+1)(x+5)
就好像形如 ax^2+bx+cax2+bx+c => pqx^2+(qk+mp)x+km=(px+k)(qx+m)pqx2+(qk+mp)x+km=(px+k)(qx+m)
但是他很蠢,他只会做p,q,m,kp,q,m,k为正整数的题目
请你帮助他,问可不可以分解
输入描述
第一行TT,表示T(1 \leq T \leq 100 )T(1T100)组数据。
接下来TT组数据:
每组数据一行,一个三个整数a,b,ca,b,c,一组数据一行 (1 \leq a,b,c \leq 100000000)(1a,b,c100000000)
输出描述
对于每组数据,输出"YES"或者"NO".
输入样例
2
1 6 5
1 6 4
输出样例
YES
NO
Hint
第一组数据可以分成(x+1)(x+5)=x^2+6*x+5(x+1)(x+5)=x2+6x+5
//a数组存放aa的因子,c数组存放cc的因子。
//直接暴力枚举所有情况。。。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define ll long long
#define N 10010
using namespace std;
struct zz
{
	int x;
	int y;
}a[N],c[N];
int main()
{
	int t,aa,bb,cc;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&aa,&bb,&cc);
		int k=0;
		for(i=1;i<=sqrt(aa);i++)
		{
			if(aa%i==0)
			{
				a[k].x=i;
				a[k++].y=aa/i;
			}
		}
		int kk=0;
		for(i=1;i<=sqrt(cc);i++)
		{
			if(cc%i==0)
			{
				c[kk].x=i;
				c[kk++].y=cc/i;
			}
		}
		int flag=0;
		for(i=0;i<k;i++)
		{
			for(j=0;j<kk;j++)
			{
				if((a[i].x*c[j].x+a[i].y*c[j].y==bb)||(a[i].x*c[j].y+a[i].y*c[j].x==bb))
				{
					flag=1;
					break;
				}
			}
		}
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值