hdu 2141 Can you find it?

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=500+1,INF=0x3f3f3f3f;
const ll mod=1e9+7;
ll a[N],b[N],c[N],d[N*N];
int main()
{
    int l,n,m;
    int cas=1;
    while(~scanf("%d%d%d",&l,&n,&m))
    {
        int k=0;
        for(int i=0; i<l; i++)
            scanf("%lld",&a[i]);
        for(int i=0; i<n; i++)
            scanf("%lld",&b[i]);
        for(int i=0; i<m; i++)
            scanf("%lld",&c[i]);
        for(int i=0; i<l; i++)
            for(int j=0; j<n; j++)
                d[k++]=a[i]+b[j];
        sort(d,d+k);
        sort(c,c+m);
        printf("Case %d:\n",cas++);
        int t;
        scanf("%d",&t);
        while(t--)
        {
            ll x;
            int flag=0;
            scanf("%lld",&x);
            for(int i=0;i<m;i++)
            {
                int tmp=x-c[i];
                int ans=*lower_bound(d,d+k,tmp);
                if(ans==tmp)
                {
                    flag=1;
                    break;
                }
            }
            if(flag) puts("YES");
            else puts("NO");
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值