Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in d

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?


Sample Input

3 
7 
9901

Sample Output

3
6
12

#include<iostream>
using namespace std;


int main()
{

int n;

while (cin >>n &&n!=EOF)
{
int ans = 1;
int m = 1;
while (m %= n)           (注意while括号中的表达式已经能表示一个值是否存在,是否有意义,不需要再写出while(m%n==0)这样写当值大到一定程度时会输不出结果 ,运行时间需要的太长了)
{

m =m * 10 + 1;
ans++;
;
}
cout <<ans<<endl;
}


return  0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值