Hashing - Hard Version

Given a hash table of size NNN, we can define a hash function . Suppose that the linear probing is used to solve collisions, we can easily obtain the status of the hash table with a given sequence of input numbers.

However, now you are asked to solve the reversed problem: reconstruct the input sequence from the given status of the hash table. Whenever there are multiple choices, the smallest number is always taken.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer NNN (≤1000\le 10001000), which is the size of the hash table. The next line contains NNN integers, separated by a space. A negative integer represents an empty cell in the hash table. It is guaranteed that all the non-negative integers are distinct in the table.

Output Specification:

For each test case, print a line that contains the input sequence, with the numbers separated by a space. Notice that there must be no extra space at the end of each line.

Sample Input:

11
33 1 13 12 34 38 27 22 32 -1 21

Sample Output:

1 13 12 21 33 34 38 27 22 32


  建图进行拓扑排序。1,13都在正确的位置,因此入度为0,而12本在位置1,而现在在位置3,所以12必须在1与13插入后才能插入,因此在1-12,13-12建立关系,同时改变12的入度。对于32,它需要除位置9以外所以点都插入才行。输出最小可用优先队列实现。(bool operator<()里不知道为啥不能用int,就写了一个很蛋疼的myint)

#include<cstdio>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
typedef struct{
	int x;
}myint;
int p[10001];
vector<int>relation[1001];
int rudu[1001];
int n;
priority_queue<myint>qu;
int ans[1001];
int cnt=0;
bool operator<(myint a,myint b)
{
	return p[a.x]>p[b.x];
}
void tuopu()
{
	int head,i,j,k;
	while (!qu.empty())
	{
		myint t; 
		t=qu.top();
		head=t.x;
		ans[cnt++]=p[head];
		qu.pop();
		for (i=0;i<relation[head].size();i++)
		{
			rudu[relation[head][i]]--;
			if (rudu[relation[head][i]]==0){
				myint t;
				t.x=relation[head][i];
				qu.push(t);
			}
				
		}
	}
}
int main()
{
	int i,j,k;
	memset(rudu,0,sizeof(rudu));
	scanf("%d",&n);
	for (i=0;i<n;i++)
		relation[i].clear();
	for (i=0;i<n;i++)
		scanf("%d",&p[i]);
	for (i=0;i<n;i++)
	{
		if (p[i]<0)
			continue;
		if (p[i]%n==i){
			myint t;
			t.x=i;
			qu.push(t);
			continue;
		}
		k=p[i]%n;
		if (k>i){
			for (j=0;j<i;j++)
			{
				relation[j].push_back(i);
				rudu[i]++;
			}
			for (j=k;j<n;j++)
			{
				relation[j].push_back(i);
				rudu[i]++;
			}
		}
		else{
			for (j=k;j<i;j++)
			{
				relation[j].push_back(i);
				rudu[i]++;
			}
		}
	 }
	tuopu(); 
//	for (i=0;i<n;i++)
//	{
//		printf("i:=%d ",i);
//		for (j=0;j<relation[i].size();j++)
//			printf(" %d",relation[i][j]);
//		printf("\n");
//	}
	for (i=0;i<cnt-1;i++)
	{
		printf("%d ",ans[i]);
	}
	printf("%d\n",ans[i]);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值