POJ 2352 stars 巴蜀OJ 1329 Stars 夜空星辰

Stars

Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 40769
Accepted: 17745

Description

Astronomers often examine star maps where stars are represented by
points on a plane and each star has Cartesian coordinates. Let the
level of a star be an amount of the stars that are not higher and not
to the right of the given star. Astronomers want to know the
distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the
star number 5 is equal to 3 (it’s formed by three stars with a numbers
1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At
this map there are only one star of the level 0, two stars of the
level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of
each level on a given map. Input

The first line of the input file contains a number of stars N
(1<=N<=15000). The following N lines describe coordinates of stars
(two integers X and Y per line separated by a space, 0<=X,Y<=32000).
There can be only one star at one point of the plane. Stars are listed
in ascending order of Y coordinate. Stars with equal Y coordinates are
listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line
contains amount of stars of the level 0, the second does amount of
stars of the level 1 and so on, the last line contains amount of stars
of the level N-1.

Sample Input 5 1 1 5 1 7 1 3 3 5 5

Sample Output 1 2 1 1 0

Hint

This problem has huge input data,use scanf() instead of cin to read
data to avoid time limit exceed.

【题目分析】
排序+平衡树的查询,感觉1s内处理10w的数据还是有点心慌,但是还是过了。

【代码】

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
struct node{
    int l,r,v,size,rnd,w;
}tr[101000];
struct star{
    int x,y;
    bool operator < (const star & a) const
    {
        return x<a.x||(x==a.x&&y<a.y);
    }
}st[101000];
int n,m,x,ans[100010],root,cnt,d=0;
inline void up (int k)
{tr[k].size=tr[tr[k].l].size+tr[tr[k].r].size+tr[k].w;}
inline void rturn(int &k)
{
    int now=tr[k].l;
    tr[k].l=tr[now].r;
    tr[now].r=k;
    tr[now].size=tr[k].size;
    up(k);
    k=now;
}
inline void lturn(int &k)
{
    int now=tr[k].r;
    tr[k].r=tr[now].l;
    tr[now].l=k;
    tr[now].size=tr[k].size;
    up(k);
    k=now;
}
inline void ins(int &k,int x)
{
    if (k==0){++cnt;k=cnt;tr[k].v=x;tr[k].size=1;tr[k].rnd=rand();tr[k].w=1;return;}
    if (tr[k].v==x) tr[k].w++;
    else if (tr[k].v>x){ins(tr[k].l,x);if (tr[tr[k].l].rnd>tr[k].rnd);rturn(k);}
    else if (tr[k].v<x){ins(tr[k].r,x);if (tr[tr[k].r].rnd>tr[k].rnd);lturn(k);}
    up(k);return;
}
int que(int p,int x)
{
    if (p==0) return 0;
    if (tr[p].v==x) return tr[p].w+tr[tr[p].l].size;
    if (x<tr[p].v) return que(tr[p].l,x);
    return tr[tr[p].l].size+tr[p].w+que(tr[p].r,x);
}
int main()
{
    scanf("%d",&n);
    for (int i=1;i<=n;++i){
        int a,b;
        scanf("%d%d",&st[i].x,&st[i].y);
    }
    sort(st+1,st+n+1);
    for (int i=1;i<=n;++i)
    {
        ans[que(root,st[i].y)]++;
        ins(root,st[i].y);
    }
    for (int i=0;i<n;i++)
      printf("%d\n",ans[i]);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值