POJ 3311 Hie with the Pie


Hie with the Pie
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6807 Accepted: 3664

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题意:给一个矩阵表示从第i个地点直接走到第j个地点的路需要多长时间,求一个送外卖的要求送到全部地点后回来所需要的最少时间。

思路:floyd+状态压缩dp,先用floyd求出两两点的最短路,再状态压缩表示哪些点走过然后dp,用第一维表示状态,第二维表示在当前状态最后所在的地点,动态转移方程:dp[后来的状态][目标地]=min(dp[后来的状态][目标地],dp[当前状态][当前状态最后所在地点])。最后还得回到原点,所以求出回到原点中最小的那个值就好了,下面给代码:

#include<iostream>
#include<cmath>
#include<queue>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#define maxn 100005
#define inf 0x3f3f3f3f
typedef long long LL;
using namespace std;
int main(){
    int n;
    int dp[1<<11][15];
    int m[15][15];
    while(scanf("%d",&n)&&n){
        memset(dp,-1,sizeof(dp));
        for(int i=0;i<=n;i++){
            for(int j=0;j<=n;j++){
                scanf("%d",&m[i][j]);
            }
        }
        for(int i=0;i<=n;i++){
            for(int j=0;j<=n;j++){
                for(int k=0;k<=n;k++){
                    m[j][k]=min(m[j][k],m[j][i]+m[i][k]);
                }
            }
        }
        for(int i=1;i<=n;i++){
            dp[1<<(i-1)][i]=m[0][i];
        }
        for(int i=1;i<(1<<n);i++){
            for(int j=1;j<=n;j++){
                if(i&(1<<(j-1))){
                    for(int k=1;k<=n;k++){
                        if(j==k)
                          continue;
                        if(i&(1<<(k-1)))
                          continue;
                       if( dp[i|(1<<(k-1))][k]==-1)
                        dp[i|(1<<(k-1))][k]=min(inf,dp[i][j]+m[j][k]);
                       else
                        dp[i|(1<<(k-1))][k]=min(dp[i|(1<<(k-1))][k],dp[i][j]+m[j][k]);
                    }
                }
                
            }
        }
        int ans=inf;
        for(int i=1;i<=n;i++){
            ans=min(ans,dp[(1<<n)-1][i]+m[i][0]);
        }
        printf("%d\n",ans);
    }
}//g++ -o a.exe a.cpp


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值