hdu 5900 QSC and Master

6 篇文章 1 订阅


QSC and Master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 753    Accepted Submission(s): 278


Problem Description
Every school has some legends, Northeastern University is the same.

Enter from the north gate of Northeastern University,You are facing the main building of Northeastern University.Ninety-nine percent of the students have not been there,It is said that there is a monster in it.

QSCI am a curious NEU_ACMer,This is the story he told us.

It’s a certain period,QSCI am in a dark night, secretly sneaked into the East Building,hope to see the master.After a serious search,He finally saw the little master in a dark corner. The master said:

“You and I, we're interfacing.please solve my little puzzle!

There are N pairs of numbers,Each pair consists of a key and a value,Now you need to move out some of the pairs to get the score.You can move out two continuous pairs,if and only if their keys are non coprime(their gcd is not one).The final score you get is the sum of all pair’s value which be moved out. May I ask how many points you can get the most?

The answer you give is directly related to your final exam results~The young man~”

QSC is very sad when he told the story,He failed his linear algebra that year because he didn't work out the puzzle.

Could you solve this puzzle?

(Data range:1<=N<=300
1<=Ai.key<=1,000,000,000
0<Ai.value<=1,000,000,000)
 

Input
First line contains a integer T,means there are T(1≤T≤10) test case。

  Each test case start with one integer N . Next line contains N integers,means Ai.key.Next line contains N integers,means Ai.value.
 

Output
For each test case,output the max score you could get in a line.
 

Sample Input
  
  
3 3 1 2 3 1 1 1 3 1 2 4 1 1 1 4 1 3 4 3 1 1 1 1
 

Sample Output
  
  
0 2 0
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5899  5897  5896  5895  5894 
题意:给你一组数,每个数有一个权值,每次你可以把某相邻的两个数去掉,并获得他们的权值,问最后你能得到的最大权值是多少。

思路:这是一道区间dp问题,首先预处理出sum[i]表示前i个权值的和,然后可以在O(n)时间复杂度内知道任意两个位置之间的权值和,然后进行区间dp,若该区间能全部取,那么dp[i][j]不为0,若不能完全取则为0。然后再进行第二次的dp,从头扫到尾就好了。。。这里我第一次dp用dp数组表示,第二次用ans数组表示,很明显有dp转移方程:ans[i]=max(ans[i],ans[j]+dp[j+1][i]);(j<i),下面给代码:

#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
typedef long long LL;
using namespace std;
#define inf 0x3f3f3f3f
#define maxn 305
typedef long long LL;
int a[maxn],g[maxn][maxn];
LL sum[maxn],dp[maxn][maxn],value[maxn],ans[maxn];
int gcd(int a, int b){
    return !b?a:gcd(b,a%b);
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=n;i++){
            scanf("%lld",&value[i]);
        }
        memset(sum,0,sizeof(sum));
        memset(dp,0,sizeof(dp));
        memset(ans,0,sizeof(ans));
        for(int i=1;i<=n;i++){
            sum[i]=sum[i-1]+value[i];
        }
        for(int i=1;i<n;i++){
            for(int j=i+1;j<=n;j++){
                g[i][j]=gcd(a[i],a[j]);
            }
        }
        for(int i=1;i<n;i++){
            if(g[i][i+1]>1){
                dp[i][i+1]=value[i]+value[i+1];
            }
        }
        for(int i=3;i<n;i+=2){
            for(int j=1;j+i<=n;j++){
                if(dp[j+1][j+i-1]==sum[j+i-1]-sum[j]&&g[j][j+i]>1){
                    dp[j][j+i]=max(dp[j][j+i],dp[j+1][j+i-1]+value[j]+value[j+i]);
                }
                if(dp[j][j+i-2]==sum[j+i-2]-sum[j-1]&&g[j+i-1][j+i]>1){
                    dp[j][j+i]=max(dp[j][j+i],dp[j][j+i-2]+value[j+i-1]+value[j+i]);
                }
                if(dp[j+2][j+i]==sum[j+i]-sum[j+1]&&g[j][j+1]>1){
                    dp[j][j+i]=max(dp[j][j+i],dp[j+2][j+i]+value[j]+value[j+1]);
                }
            }
        }
        for(int i=2;i<=n;i++){
            for(int j=0;j<i;j++){
                ans[i]=max(ans[i],ans[j]+dp[j+1][i]);
            }
        }
        printf("%lld\n",ans[n]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值