Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 12774 | Accepted: 6427 |
Description
If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., a, a + d, a + 2d, a + 3d, a + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837.
For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,
2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,
contains infinitely many prime numbers
2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .
Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers a, d, and n.
Input
The input is a sequence of datasets. A dataset is a line containing three positive integers a, d, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346, and n <= 210.
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.
Output
The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.
The output integer corresponding to a dataset a, d, n should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.
FYI, it is known that the result is always less than 106 (one million) under this input condition.
Sample Input
367 186 151 179 10 203 271 37 39 103 230 1 27 104 185 253 50 85 1 1 1 9075 337 210 307 24 79 331 221 177 259 170 40 269 58 102 0 0 0
Sample Output
92809 6709 12037 103 93523 14503 2 899429 5107 412717 22699 25673
#include<iostream>
#include<cmath>
using namespace std;
//1000000以内质数数组,Primenum计数
int Prime[1000000];
int Primenum = 0;
void Primearray(int *p)
{
int i,j;
int flag;
for(i=2;i<1000000;i++)
{
flag = 1;
for(j=2;j<=(int)sqrt(i);j++)
{
if(i%j==0)
flag = 0;
}
if(flag==1)
{
*p = i;
p++;
Primenum++;
}
}
}
int main()
{
int a,d,n;
//output[100]存储输出数据
int output[100];
int outputnum = 0;
Primearray(Prime);
while(true)
{
cin>>a>>d>>n;
if(a==0&&d==0&&n==0)
break;
int i=0;
//count计数a+kd数列中的质数是第多少个,l循环加,find标记找到既终止
int count =0;
int l=a;
int find = 0;
while(true)
{
//i递增
for(;i<Primenum;i++)
{
//判断l是否是质数,是则判断是否是第n个
if(l==Prime[i])
{
count++;
if(count==n)
{
output[outputnum]=l;
outputnum++;
find = 1;
}
break;
}
if(l<Prime[i])
break;
}
l = l+d;
if(find==1)
break;
}
}
//输出
cout<<"----------------------------------"<<endl;
for(int i=0;i<outputnum;i++)
cout<<output[i]<<endl;
}