Poj 3984 迷宫问题

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5099 Accepted: 2895

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

这个题目不陌生额,虽然它后台测试数据只有一组,还是好好的A掉。

bfs+模拟队列   记录路径。。。。具体的代码说吧。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;
struct node//记录路径
{
    int x,y;
    int pre;
} index[105];

int map[10][10];//图
int front=0,last=1;//入队与出队
int d[4][2] = {{-1,0},{0,1},{1,0},{0,-1}};
bool inside(int x1,int y1)//是否在界内
{
    if(x1<0 || x1>=5 || y1<0 || y1>=5)
        return false;
    return true;
}

void print(int n)//打印结果
{
    if(index[n].pre != -1)
    {
        print(index[n].pre);
        printf("(%d, %d)\n",index[n].x,index[n].y);
    }
}

void bfs(int x1,int y1)
{
    int i;
    index[front].x = x1;//入队
    index[front].y = y1;
    index[front].pre = -1;
    while(front < last)//队列为空停止
    {
        for(i=0; i<4; i++)
        {
            int dx=index[front].x+d[i][0];
            int dy=index[front].y+d[i][1];
            if(dx == 4 && dy == 4)//找到终点
            {
                print(front);
                printf("(4, 4)\n");
                break;
            }
            if(inside(dx,dy) && map[dx][dy] == 0)
            {
                map[dx][dy] = 1;
                index[last].x = dx;//入队
                index[last].y = dy;
                index[last].pre = front;//记录相关联的上一点
                last ++;
            }
        }
        front++;//前一个出列
    }
}
int main()
{
    int i,j;
    for(i=0; i<5; i++)
    {
        for(j=0; j<5; j++)
        {
            scanf("%d",&map[i][j]);
        }
    }
     printf("(0, 0)\n");
        bfs(0,0);
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值