POJ 3984 BFS走迷宫问题

POJ 3984 BFS走迷宫问题,题目的链接如下:
http://poj.org/problem?id=3984

A - 迷宫问题
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit

Status
Description
定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

#include <iostream>//代码是找的,做一下午已经死了
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <functional>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
const int N = 5 ;
using namespace std;
struct note
{
    int x,y,pre;//存放坐标,前一个节点在队列中的位置
} que[100];
int map1[N][N];
int Nx[4]= {1,-1,0,0};
int Ny[4]= {0,0,-1,1};
int start=0,end=1;//用que结构体数组模拟一个队列
void print(int s)
{
    if(que[s].pre!=-1)
    {
        //递归输出
        print(que[s].pre);//根据查找前一个的位置来递归
        cout<<"("<<que[s].x<<", "<<que[s].y<<")"<<endl;
    }
}
void bfsMap(int x,int y)
{
    que[start].pre=-1;
    que[start].x=x;
    que[start].y=y;
    while(start<end)
    {
        for(int i=0; i<4; i++)
        {
            int a=Nx[i]+que[start].x;
            int b=Ny[i]+que[start].y;
            if(a<0 || b<0 || a>=N || b>=N || map1[a][b])//如果出界或者遇到墙或者已经被访问
                continue;
            else
            {
                map1[a][b]=-1;//设置已经访问过
                //入队
                que[end].pre=start;
                que[end].x=a;
                que[end].y=b;
                end++;//数组大小
            }
            if(a==N-1 && b==N-1)
                print(start);
        }
        start++;
    }
}
int main()
{
    int i,j;
    for(i=0; i<N; i++)
        for(j=0; j<N; j++)
            scanf("%d",&map1[i][j]);
    cout<<"(0, 0)"<<endl;
    bfsMap(0,0);
    cout<<"("<<N-1<<", "<<N-1<<")"<<endl;
    return 0;
}
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索法来解决这个问题。 下面是一个使用广度优先搜索法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向组 static boolean[][] vis = new boolean[5][5]; // 标记组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记组记录已经访问过的位置,使用路径组记录路径。最后,使用栈来输出路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值