HDU 4465 (candy)(期望+log优化)

Candy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2890    Accepted Submission(s): 1305
Special Judge


Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
 

Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 10 5) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10 -4 would be accepted.
 

Sample Input
  
  
10 0.400000 100 0.500000 124 0.432650 325 0.325100 532 0.487520 2276 0.720000
 

Sample Output
  
  
Case 1: 3.528175 Case 2: 10.326044 Case 3: 28.861945 Case 4: 167.965476 Case 5: 32.601816 Case 6: 1390.500000
 

Source

分析:有2个大小为n的盒子,里面放满了糖果,有个小孩一天吃一个,然后直到一天有一个盒子吃完了,算一下另外一个盒子的期望。

简单暴力的期望题目,但是呢不会做,因为没看过类似期望的东西,训练赛后推公式补题。

第一个盒子的概率是P  第二个盒子的概率是(1-p)

得到公式:C(n+i,i)*(p^(n+1)*(1-p)^i+p^i*(1-p)^(n+1))*(n-i)

第n+i+1次是代表取空了某一个盒子,所以就不再C()里面了,所以只需要考虑n+i的情况即可。

当然包括了两种情况第一个盒子吃完第二个盒子吃完,所以应该ln后将两种情况加起来。

ln的式子是: ln(C(n+i, i)) + (n+1)*ln(p) + (i)*ln(1-p) 。

这是其中一个的概率,另外一个P和(1-P)换一下位置。


#include<stdio.h>
#include<iostream> 
#include <algorithm>
#include<string.h>
#include<vector>
#include<math.h>
#include<queue>
#include<set>
#define LL long long
#define INf 0x3f3f3f3f
#define mod 1000000007
using namespace std;
double t[400010];//存放Log的概率 
void in()//预处理 Log 
{
	t[0]=0;
	for(int i=1;i<=400000;i++)
		t[i]=t[i-1]+log(i);
} 
double logc(int n,int m)//数学公式 
{
	return t[n]-t[m]-t[n-m];
}
int main()
{
	int n,count=1;
	in();
	double p,p1;
	while(scanf("%d%lf",&n,&p)!=EOF)
	{
		p1=1-p;
		p=log(p);
		p1=log(p1);
		double ans=0;
		double ans1=0;
		double ans2=0;
		for(int i=0;i<n;i++)//从另外一个箱子取走的糖果数目 
		{
			ans=logc(n+i,i)+(n+1)*p+i*p1;
			ans1=logc(n+i,i)+(n+1)*p1+i*p; 
			ans2=ans2+(exp(ans)+exp(ans1))*(n-i);//exp是e为底的函数 
		}
		printf("Case %d: %.6lf\n",count++,ans2);	
	} 
	return 0;
} 
特别说明下:(n-i)代表的是剩下的糖果,期望等于概率乘以变量。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值