【暴力】POJ2258-ZOJ1947-UVA539-The-Settlers-of-Catan

9 篇文章 0 订阅
4 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 65536K

Description

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.
You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game’s special rules:

When the game ends, the player who built the longest road gains two extra victory points.
The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).
Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes.
The longest road is defined as the longest path within the network that doesn’t use an edge twice. Nodes may be visited more than once, though.

Example: The following network contains a road of length 12.

o      o--o      o

 \    /    \    /

  o--o      o--o

 /    \    /    \

o      o--o      o--o

           \    /

            o--o

Input

The input will contain one or more test cases.
The first line of each test case contains two integers: the number of nodes n (2<=n<=25) and the number of edges m (1<=m<=25). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.
Input will be terminated by two values of 0 for n and m.
Output

For each test case, print the length of the longest road on a single line.

Sample Input

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output

2
12

Source

Ulm Local 1998

题意

给你一个无向图,问其中的最长边是多少。

思路

拿邻接矩阵把所有的边存进去,然后用dfs每个点都扫一遍,不断更新最长边即可。
数据很小,直接暴力写就好。

AC代码

#include <cstdio>
#include <cstring>
using namespace std;

/*
19792272	pengrj	2258	Accepted	4228K	16MS	G++	844B	2019-02-16 11:08:57
*/

int n, m;
const int maxn = 1e3;
int Map[maxn][maxn];
int ans;

void dfs(int tans, int j)
{
    for (int i = 0; i < n; i++)
    {
        if (Map[j][i] == 1)
        {
            Map[j][i] = Map[i][j] = 0;
            dfs(tans + 1, i);
            Map[j][i] = Map[i][j] = 1;
        }
    }
    ans = tans > ans ? tans : ans;
}

void solve(void)
{
    while (~scanf("%d%d", &n, &m))
    {
        if (n == m && n == 0)
            break;
        memset(Map, 0, sizeof Map);
        ans = 0;
        for (int i = 0; i < m; i++)
        {
            int x, y;
            scanf("%d%d", &x, &y);
            Map[x][y] = Map[y][x] = 1;
        }
        for (int i = 0; i < n; i++)
            dfs(0, i);
        printf("%d\n", ans);
    }
}

int main(void)
{
    solve();
    return 0;
}

创作于:2019-02-16

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

两米长弦

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值