Fibonacci Again

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n). Print the word “no” if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no
建立数组逐个循环求出输入数字的值
这一步注意后来的值可能越界,需要一边计算一边%
注意考虑 a【0】和 a【1】的特殊性 需要单独修改
因为数组过大 需要全局变量
代码如下
#include<stdio.h>
int a[1000005];
int main()
{
a[0] = 7;
a[1] = 11;
int n;
for(int i=2;i<1000005;i++){
a[i] = (a[i-1] + a[i-2])%3;
}
a[0]=1;
a[1]=2;
while(scanf("%d",&n)!=EOF){
if(a[n]==0){
printf(“yes\n”);
}
else {
printf(“no\n”);
}
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值