【1222】 杭电OJ

Problem Description

There is a hill with n holes around. The holes are signed from 0 to n-1.
 



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

 

 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

 

 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

 

 

Sample Input

 

2 1 2 2 2

 

 

Sample Output

 

NO YES

 

 

Author

weigang Lee

 

 

Source

杭州电子科技大学第三届程序设计大赛

 

 

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:  1207 1299 1219 2175 1995 

 

解析:

    ① 如果 m =1 ,意味着每一个洞狼都可以进去,所以兔子必须死;如果 n =1 ,意味着兔子只能进第 0 洞,依旧是die。

    ② 如果 m 和 n 的最大公约数 a 不为 1 ,则意味着 0,m , 2m , 3m , .... , 0 , a .... 转了一圈以后会进入第 a 洞中,而往后经过数次转圈都会踩在同一个洞里,所以有其余的洞是狼不能进的。故兔子存活。

 

   0 ,6 ,  3 ,0 , 6 ,3 ,0.....

 

#include<iostream>
#include<stdio.h>
#include<string>
using namespace std;

//求最大公约数 
int Hmax(int a,int b)       
{
    int r=0;
    while(b!=0)
    {
        r=a%b;
        a=b;
        b=r;
    }
    return a;
}

int main(){
	int num,n,m;
	while(cin>>num){
		while(num--){
			cin>>m>>n;
		if(m==1||n==1)
			cout<<"NO"<<endl;
		else if(Hmax(n,m)==1)
			cout<<"NO"<<endl;
		else
			cout<<"YES"<<endl;
		}		
	}
	return 0;
}

提交结果:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值